Maven Site Plugin
  1. Maven Site Plugin
  2. MSITE-130

Site generation fails for site.xml in UTF8 with BOM

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0-beta-6
    • Component/s: encoding
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I get the following error if I edit site.xml with Windows Notepad.

      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error during page generation

      Embedded error: Can't read site descriptor.
      only whitespace content allowed before start tag and not \uef (position: START_DOCUMENT seen \uef... @1:1)

      This is due to http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4508058 . Since Sun is saying they won't fix this "RFE" (which I think is a bug), we need a workaround.

        Issue Links

          Activity

          Herve Boutemy added a comment -

          the problem is more general: encoding support for site.xml

          Herve Boutemy added a comment -

          XML encoding support is fixed for site.xml and every xdoc file, fml, and so on
          to be precise, BOM is supported for UTF-8 and UTF-16, but not UTF-32


            People

            • Assignee:
              Herve Boutemy
              Reporter:
              Shinobu Kawai
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: