Maven Site Plugin
  1. Maven Site Plugin
  2. MSITE-121

Generated html files contain inconsistent new lines

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta-4
    • Fix Version/s: 3.4
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Issue Links

        Activity

        Aaron Zeckoski added a comment -

        Reproducing this is easy. Here are the steps (using OSX 10.5.6)

        dhcp-91:entitybus-1.0.0 azeckoski$ mvn site:site
        [INFO] Scanning for projects...
        [INFO] Reactor build order:
        [INFO] Entity Bus
        [INFO] Entity Bus API
        [INFO] Entity Bus Utilities
        [INFO] Entity Bus Mock Objects
        [INFO] Entity Bus Manager Implementation
        [INFO] Entity Bus REST Implementation
        [INFO] Searching repository for plugin with prefix: 'site'.
        [INFO] ------------------------------------------------------------------------
        [INFO] Building Entity Bus
        [INFO] task-segment: [site:site]
        [INFO] ------------------------------------------------------------------------
        [INFO] [site:site]
        [INFO] Generating "Plugin Management" report.
        [INFO] Generating "Mailing Lists" report.
        [INFO] Generating "Continuous Integration" report.
        ... (snip)
        [INFO] Entity Bus REST Implementation ........................ SUCCESS [19.505s]
        [INFO] ------------------------------------------------------------------------
        [INFO] ------------------------------------------------------------------------
        [INFO] BUILD SUCCESSFUL
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 1 minute 14 seconds
        [INFO] Finished at: Thu Jan 29 10:29:39 GMT 2009
        [INFO] Final Memory: 33M/254M
        [INFO] ------------------------------------------------------------------------
        dhcp-91:tmp azeckoski$ svn checkout https://entitybus.googlecode.com/svn/maven/ eb-maven --username azeckoski
        Checked out revision 9.
        dhcp-91:tmp azeckoski$ cd eb-maven
        dhcp-91:eb-maven azeckoski$ cp -R /tmp/entitybus/site .
        dhcp-91:eb-maven azeckoski$ ls -al
        total 0
        drwxr-xr-x 4 azeckoski wheel 136 29 Jan 10:38 .
        drwxrwxrwt 23 root wheel 782 29 Jan 10:38 ..
        drwxr-xr-x 9 azeckoski wheel 306 29 Jan 10:38 .svn
        drwxr-xr-x 23 azeckoski wheel 782 29 Jan 10:38 site
        dhcp-91:eb-maven azeckoski$ svn add site
        A site
        A site/css
        A site/css/maven-base.css
        A site/css/maven-theme.css
        A site/css/print.css
        A site/css/site.css
        svn: File 'site/dependencies.html' has inconsistent newlines
        svn: Inconsistent line ending style
        dhcp-91:eb-maven azeckoski$ svn help add
        add: Put files and directories under version control, scheduling
        them for addition to repository. They will be added in next commit.
        usage: add PATH...

        dhcp-91:eb-maven azeckoski$ svn --version
        svn, version 1.5.5 (r34862)
        compiled Jan 5 2009, 12:30:39

        Copyright (C) 2000-2008 CollabNet.
        Subversion is open source software, see http://subversion.tigris.org/
        This product includes software developed by CollabNet (http://www.Collab.Net/).

        The following repository access (RA) modules are available:

        • ra_neon : Module for accessing a repository via WebDAV protocol using Neon.
        • handles 'http' scheme
        • handles 'https' scheme
        • ra_svn : Module for accessing a repository using the svn network protocol.
        • with Cyrus SASL authentication
        • handles 'svn' scheme
        • ra_local : Module for accessing a repository on local disk.
        • handles 'file' scheme
        • ra_serf : Module for accessing a repository via WebDAV protocol using serf.
        • handles 'http' scheme
        • handles 'https' scheme

        dhcp-91:eb-maven azeckoski$ mvn --version
        Maven version: 2.0.9
        Java version: 1.5.0_16
        OS name: "mac os x" version: "10.5.6" arch: "i386" Family: "unix"

        Lukas Theussl added a comment -

        Just checked with site-plugin-2.1-SNAPSHOT (doxia-1.1.1) and this is still not fixed. I'm afraid it will be hard to track down though...

        Herve Boutemy added a comment -

        as I understand this issue, resources (*.css for exemple) are copied as binary data, then with line endings of the machine of the guy who released the skin (svn did the job when doing checkout)

        but reports are generated with current machine's line ending

        Then there is a problem when one of the guys is under Windiws and the other under Unix.

        Fixing this will require to know when to do a binary copy (images for example), and when to do a text copy (*.css for example).

        WDYT?

        Herve Boutemy added a comment -

        perhaps MSITE-453 could help us: adding a dedicated packaging, and eventually a skin descriptor to define useful info about a skin, instead of using a simple jar, could help us imrpove skins support

        Herve Boutemy added a comment -

        I just fixed DOXIASITETOOLS-87: generated html files are now consistent

        AFAIK, resources (*.css) are not a problem, since they are consistent (no newline mix inside one file) and svn accepts if the file doesn't have same newlines than current host


          People

          • Assignee:
            Herve Boutemy
            Reporter:
            Carlos Sanchez
          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: