Maven Shared Components
  1. Maven Shared Components
  2. MSHARED-18

Inheritance of elements from site descriptor quite broken

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: maven-doxia-tools-1.0
    • Component/s: maven-doxia-tools
    • Labels:
      None
    • Environment:
      Maven 2.0.8, JDK 1.5.0_12, WinXP
    • Number of attachments :
      6

      Description

      After updating to 2.0-beta-6, I never get proper site output for multi module projects. I attached a simple dummy project that shall help to reproduce the problem.

      When I perform a reactor build of the site (i.e. "project-parent> mvn site"), the pages of the sub module project-module-1 properly inherit most of the decorator elements, except for the custom "overview" menu. That is, the site of the sub module contains the menu configured for the parent project despite the sub module specifying its own menu.-

      In contrast, when I only build the site of the sub module (i.e. "project-module-1> mvn site"), many decoration elements are not inherited from the parent's site.xml like <version>, <bannerRight>, <skin>, <links>. However, now the sub module's site properly outputs its own menu items (i.e. "Module-Item" instead of "Parent-Item" for the attached projects).

      This issues might be a duplicate/relative of MSITE-256 but as I cannot safely judge from its description, I opened a new issue.

      1. site-directory.patch
        4 kB
        Benjamin Bentmann
      2. site-directory.patch
        8 kB
        Benjamin Bentmann
      3. exception.txt
        3 kB
        Anne Gerodolle

        Issue Links

          Activity

          Anne Gerodolle added a comment -

          with current version of maven-site-plugin rebuilt from svn trunk, module site is not built when typing mvn clean then mvn site

          Anne Gerodolle added a comment -

          exceptionraised when trying to build the site (bug1.zip)

          Anne Gerodolle added a comment -

          modules sites are built but a menu that should be inherited is not

          Benjamin Bentmann added a comment -

          Moreover, if I do not specify some "<url>" tag in the parent pom.xml, I now observe an exception I did not obtain before.

          Looks like you ran into MSITE-180.

          Anne Gerodolle added a comment -

          "Looks like you ran into MSITE-180."
          it may be related however symptoms are not the same: it's not that "IF none of the poms (module or parent) don't have an url tag,
          THEN site inheritence quitely isn't applied, for example in the parent's site.xml".
          what I observe is : the child's site is not built at all if the url tag is missing. and an exception is raised (exception.txt).

          a difficulty for reporting these issues correctly is that behaviour of inheritance seems quite instable. Sometimes, menus are not inherited, sometimes, only menus from parents are shown. Sometimes, skins are not inherited, or partially, sometimes they are...

          In the example bug2.zip, with the site plugin checked out from trunk and rebuilt yesterday,if I run "mvn site" in the parent's folders, menu "menu1" is not inherited.

          And I'm sorry for the numerous small posts of yesterday : I tried to add a comment to each uploaded file, but clearly it does not work like that !


            People

            • Assignee:
              Vincent Siveton
              Reporter:
              Benjamin Bentmann
            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: