Maven Shared Components
  1. Maven Shared Components
  2. MSHARED-142

mvn not found when invoking the verifier from IDEA

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: maven-verifier
    • Labels:
      None
    • Environment:
      MacOsX
    • Number of attachments :
      0

      Description

      When i use the verifier in Intellij IDEA, the verifier is unable to find mvn in the path. I don't have the problem on Linux/Windows XP.

      The path is set properly

      org.apache.maven.it.VerificationException: org.apache.maven.it.util.cli.CommandLineException: Error while executing process.
      	at org.apache.maven.it.Verifier.executeGoals(Verifier.java:907)
      	at org.apache.maven.it.Verifier.executeGoal(Verifier.java:780)
      	at org.apache.maven.it.Verifier.executeGoal(Verifier.java:774)
      	at org.apache.maven.plugin.ear.AbstractEarPluginTestCase.executeMojo(AbstractEarPluginTestCase.java:84)
      	at org.apache.maven.plugin.ear.AbstractEarPluginTestCase.executeMojo(AbstractEarPluginTestCase.java:114)
      	at org.apache.maven.plugin.ear.AbstractEarPluginTestCase.doTestProject(AbstractEarPluginTestCase.java:132)
      	at org.apache.maven.plugin.ear.AbstractEarPluginTestCase.doTestProject(AbstractEarPluginTestCase.java:161)
      	at org.apache.maven.plugin.ear.EarMojoTest.testProject038(EarMojoTest.java:411)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at com.intellij.rt.execution.junit.JUnitStarter.main(JUnitStarter.java:40)
      Caused by: org.apache.maven.it.util.cli.CommandLineException: Error while executing process.
      	at org.apache.maven.it.util.cli.Commandline.execute(Commandline.java:737)
      	at org.apache.maven.it.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:101)
      	at org.apache.maven.it.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:87)
      	at org.apache.maven.it.Verifier.executeGoals(Verifier.java:901)
      	... 23 more
      Caused by: java.io.IOException: mvn: not found
      	at java.lang.UNIXProcess.forkAndExec(Native Method)
      	at java.lang.UNIXProcess.<init>(UNIXProcess.java:52)
      	at java.lang.ProcessImpl.start(ProcessImpl.java:91)
      	at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
      	at java.lang.Runtime.exec(Runtime.java:591)
      	at org.apache.maven.it.util.cli.Commandline.execute(Commandline.java:732)
      	... 26 more
      

        Activity

        Stéphane Nicoll added a comment -

        The environment passe to Runtime.getRuntime does not contain the actual PATH variable.

        PATH=/usr/bin:/bin:/usr/sbin:/sbin
        

        My bash shell gives the following:

        cobra:~/projects/maven-shared/maven-verifier snicoll$ echo $PATH
        /bin:/sbin:/usr/bin:/usr/sbin:/opt/local/bin:/opt/tools/maven/bin:/opt/tools/ant/bin
        
        Stéphane Nicoll added a comment -

        Creating a simlink in /usr/bin fixes the issue.

        Michael Osipov added a comment -

        Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.


          People

          • Assignee:
            Unassigned
            Reporter:
            Stéphane Nicoll
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: