Maven Shade Plugin
  1. Maven Shade Plugin
  2. MSHADE-86

dependencies of excluded dependencies are included

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 1.4
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Please let me know if you need a test case here.

      Pom has two executions of shade on separate classifiers. One of them uses excludes to leave some things out. Final jar includes contents of a slew of other artifacts. Dependency:tree shows those artifacts as being dependencies of the excluded artifacts, not the included ones.

        Activity

        Benjamin Bentmann added a comment -

        Please let me know if you need a test case here.

        We always do.

        Benson Margulies added a comment -

        Well, you always do if you agree that this is undesirable behavior . If your reply has been 'that's what we intended', I would have been happy not to have troubled with a test case.

        Benson Margulies added a comment -

        I don't have time to chase this.


          People

          • Assignee:
            Unassigned
            Reporter:
            Benson Margulies
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: