Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.1
    • Component/s: rpm
    • Labels:
      None
    • Environment:
      Mac OS X Snow Leopard with rpm 4.4.9 (installed via ports)
    • Number of attachments :
      0

      Description

      I haven't looked at the source yet to confirm but my suspicion is that the spaces in the auto detected system os are the cause.
      For example:
      [INFO] RPM build execution returned: '1' executing '/bin/sh -c cd /Users/dwhitla/dev/travel.com.au/travel-vhost-static.travel.com.au/trunk/target/rpm/travel-vhost-static.travel.com.au/SPECS && rpmbuild -bb --buildroot /Users/dwhitla/dev/travel.com.au/travel-vhost-static.travel.com.au/trunk/target/rpm/travel-vhost-static.travel.com.au/buildroot --define '_topdir /Users/dwhitla/dev/travel.com.au/travel-vhost-static.travel.com.au/trunk/target/rpm/travel-vhost-static.travel.com.au' --target 'noarch-apple-mac os x' travel-vhost-static.travel.com.au.spec'

        Activity

        Dave Whitla added a comment -

        Too quick - local environment issue

        Dave Whitla made changes -
        Field Original Value New Value
        Fix Version/s 2.0.1 [ 16213 ]
        Resolution Not A Bug [ 6 ]
        Status Open [ 1 ] Closed [ 6 ]
        Dave Whitla added a comment -

        For the benefit of anyone else who has this issue the RPM distro available from macports does not set %_tmppath to any default value.
        One way of addressing the problem is to add this to the rpm-maven-plugin configuration:
        <!-- _tmppath is not set correctly on Mac OS X so it is forced here -->
        <defineStatement>_tmppath /tmp</defineStatement>

        Alternatively you could add the following to ~/.rpmmacros:
        %_tmppath /tmp


          People

          • Assignee:
            Brett Okken
            Reporter:
            Dave Whitla
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: