Mojo's RPM Maven Plugin
  1. Mojo's RPM Maven Plugin
  2. MRPM-102

path with space using the directoryIncluded causes rpmbuild failure

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1-alpha-1
    • Fix Version/s: 2.1-alpha-2
    • Component/s: rpm
    • Labels:
      None
    • Environment:
      redhat enterprise linux 6.1, 5.5, ubuntu with rpm build tools
    • Number of attachments :
      1

      Description

      using the maven rpm plugin to bundle the geronimo tarball and having another mapping contribute to the target location causes the plugin to list every file in the spec file. due to the way that rpmbuild parses that file a space counts as 2 files on the same line. this causes a build failure.

      the issue is in the specwriter class, you just need to add a quote before and after destination when writing the path to the spec file

        Activity

        scott brinkmeyer added a comment -

        this patch is my working changes for adding quotes around the paths created by the rpm plugin to have rpmbuild deal with spaces correctly

        Anders Hammar added a comment -

        Committed in r16369. Issue seen in IT rpm-1 on my Mac, which verifies the fix.


          People

          • Assignee:
            Anders Hammar
            Reporter:
            scott brinkmeyer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: