Archiva
  1. Archiva
  2. MRM-884

network proxy fails after upgrading to archiva 1.1

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.1.1
    • Component/s: remote proxy
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I'm trying to upgrade from 1.0 to 1.1. I use a network proxy to access remote repos. When using 1.0, I get no error, and when using 1.1, I get this error.
      I double checked my configuration, and there is no differences between my 1.0's config and my 1.1's config.

      http://www.nabble.com/Upgrade-from-1.0-to-1.1-%3A-network-problem-td18587462.html

      2008-07-22 15:02:40,099 [btpool0-7] DEBUG org.apache.maven.archiva.policies.AbstractUpdatePolicy - OK to update, snapshot policy does not apply for non-snapshot versions.
      2008-07-22 15:02:40,099 [btpool0-7] DEBUG org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors - No authentication for remote repository needed
      2008-07-22 15:02:40,114 [btpool0-7] DEBUG org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors - Retrieving org/apache/maven/plugins/maven-site-plugin/2.0-beta-6/maven-site-plugin-2.0-beta-6.pom from Central Repository
      2008-07-22 15:02:57,395 [btpool0-7] DEBUG org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors - Applying [propagate-errors-on-update] policy with [artifact not already present]
      2008-07-22 15:02:57,395 [btpool0-7] DEBUG org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors - Applying [propagate-errors] policy with [queue error]
      2008-07-22 15:02:57,395 [btpool0-7] WARN org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors - Transfer error from repository "central" for artifact org.apache.maven.plugins:maven-site-plugin:2.0-beta-6::pom, continuing to next repository. Error message: Download failure on resource http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-site-plugin/2.0-beta-6/maven-site-plugin-2.0-beta-6.pom:Error transferring file
      2008-07-22 15:02:57,410 [btpool0-7] DEBUG org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors - Full stack trace
      org.apache.maven.archiva.proxy.ProxyException: Download failure on resource http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-site-plugin/2.0-beta-6/maven-site-plugin-2.0-beta-6.pom:Error transferring file
      at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.transferSimpleFile(DefaultRepositoryProxyConnectors.java:747)
      at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.transferFile(DefaultRepositoryProxyConnectors.java:564)
      at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.fetchFromProxies(DefaultRepositoryProxyConnectors.java:171)
      at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.fetchContentFromProxies(ArchivaDavResourceFactory.java:520)
      at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.doGet(ArchivaDavResourceFactory.java:423)
      at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.createResource(ArchivaDavResourceFactory.java:251)
      at org.apache.maven.archiva.webdav.RepositoryServlet.service(RepositoryServlet.java:119)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
      at com.opensymphony.webwork.dispatcher.FilterDispatcher.doFilter(FilterDispatcher.java:189)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:39)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at com.opensymphony.webwork.dispatcher.ActionContextCleanUp.doFilter(ActionContextCleanUp.java:88)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
      at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:722)
      at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:404)
      at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
      at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
      at org.mortbay.jetty.Server.handle(Server.java:324)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
      at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:828)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
      at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
      at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)
      Caused by: org.apache.maven.wagon.TransferFailedException: Error transferring file
      at org.apache.maven.wagon.providers.http.LightweightHttpWagon.fillInputData(LightweightHttpWagon.java:136)
      at org.apache.maven.wagon.StreamWagon.getInputStream(StreamWagon.java:116)
      at org.apache.maven.wagon.StreamWagon.getIfNewer(StreamWagon.java:88)
      at org.apache.maven.wagon.StreamWagon.get(StreamWagon.java:61)
      at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.transferSimpleFile(DefaultRepositoryProxyConnectors.java:704)
      ... 31 more
      Caused by: java.net.UnknownHostException: repo1.maven.org
      at java.net.PlainSocketImpl.connect(Unknown Source)
      at java.net.Socket.connect(Unknown Source)
      at java.net.Socket.connect(Unknown Source)
      at sun.net.NetworkClient.doConnect(Unknown Source)
      at sun.net.www.http.HttpClient.openServer(Unknown Source)
      at sun.net.www.http.HttpClient.openServer(Unknown Source)
      at sun.net.www.http.HttpClient.<init>(Unknown Source)
      at sun.net.www.http.HttpClient.New(Unknown Source)
      at sun.net.www.http.HttpClient.New(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
      at org.apache.maven.wagon.providers.http.LightweightHttpWagon.fillInputData(LightweightHttpWagon.java:115)
      ... 35 more

        Issue Links

          Activity

          Jochen Wiedmann added a comment -

          Does this actually work? I have checked out archiva 1.1, applied the changes from rev. 680127, built archiva-proxy-1.1.jar and replaced the original one with the newly built version. However, network proxies still aren't working.

          OTOH, I don't find an UnknownHostException in my log files? And DNS works for sure on my system?

          Jochen Wiedmann added a comment -

          Ok, cancel my previous reply. I have replaced wagon-provider-api and it works immediately.


            People

            • Assignee:
              Brett Porter
              Reporter:
              Dominique Jean-Prost
            • Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: