Archiva
  1. Archiva
  2. MRM-790

[regression] proxying metadata causes an IO exception in new checksum code

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.1
    • Component/s: remote proxy
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Steps to reproduce:
      1) remove /activemq/activemq-gbean-management/*.xml and associated checksums on the filesystem
      2) request /activemq/activemq-gbean-management/maven-metadata.xml via Archiva

      Exception:

      2008-05-06 19:02:39,097 [btpool0-7] WARN org.apache.archiva.checksum.ChecksummedFile - Supplied checksum does not match checksum pattern
      java.io.IOException: Supplied checksum does not match checksum pattern
      at org.apache.archiva.checksum.ChecksummedFile.parseChecksum(ChecksummedFile.java:336)
      at org.apache.archiva.checksum.ChecksummedFile.fixChecksums(ChecksummedFile.java:269)
      at org.apache.maven.archiva.policies.ChecksumPolicy.applyPolicy(ChecksumPolicy.java:129)
      at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.validatePolicies(DefaultRepositoryProxyConnectors.java:774)
      at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.transferFile(DefaultRepositoryProxyConnectors.java:602)
      at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.fetchFromProxies(DefaultRepositoryProxyConnectors.java:351)
      at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.fetchMetadataFromProxies(ArchivaDavResourceFactory.java:283)
      at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.fetchContentFromProxies(ArchivaDavResourceFactory.java:225)
      at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.doGet(ArchivaDavResourceFactory.java:151)
      at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.createResource(ArchivaDavResourceFactory.java:111)
      at org.apache.maven.archiva.web.repository.RepositoryServlet.service(RepositoryServlet.java:107)

        Activity

        Maria Odea Ching added a comment -

        I'm getting the IOException, but the error message is different..

        2008-05-28 10:11:03,552 [btpool0-8] WARN org.apache.archiva.checksum.ChecksummedFile - Supplied checksum file '/home/maven/repository-staging/to-ibiblio/maven2/javax/activation/activation/maven-metadata.xml' does not match expected file: 'maven-metadata-central.xml'
        java.io.IOException: Supplied checksum file '/home/maven/repository-staging/to-ibiblio/maven2/javax/activation/activation/maven-metadata.xml' does not match expected file: 'maven-metadata-central.xml'
        at org.apache.archiva.checksum.ChecksummedFile.parseChecksum(ChecksummedFile.java:337)
        at org.apache.archiva.checksum.ChecksummedFile.fixChecksums(ChecksummedFile.java:269)
        at org.apache.maven.archiva.policies.ChecksumPolicy.applyPolicy(ChecksumPolicy.java:129)
        at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.validatePolicies(DefaultRepositoryProxyConnectors.java:774)
        at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.transferFile(DefaultRepositoryProxyConnectors.java:602)
        at org.apache.maven.archiva.proxy.DefaultRepositoryProxyConnectors.fetchFromProxies(DefaultRepositoryProxyConnectors.java:351)
        at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.fetchMetadataFromProxies(ArchivaDavResourceFactory.java:407)
        at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.fetchContentFromProxies(ArchivaDavResourceFactory.java:348)
        at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.doGet(ArchivaDavResourceFactory.java:264)
        at org.apache.maven.archiva.webdav.ArchivaDavResourceFactory.createResource(ArchivaDavResourceFactory.java:191)
        at org.apache.maven.archiva.web.repository.RepositoryServlet.service(RepositoryServlet.java:104)

        Maria Odea Ching added a comment -

        Looking at the codes, it seems the error message was changed since this issue was filed so that's why we encountered different error messages

        Maria Odea Ching added a comment -

        Fixed in trunk -r661273:

        • added check specifically for remote metadata checksum files
        • added test case

          People

          • Assignee:
            Maria Odea Ching
            Reporter:
            Brett Porter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: