Archiva
  1. Archiva
  2. MRM-653

WebDAV deploy fails with error

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.1
    • Component/s: WebDAV Interface
    • Labels:
      None
    • Environment:
      Linux
      Sun's jdk1.6.0_03
      Tomcat 6.0.14
    • Number of attachments :
      1

      Description

      I was having problems deploying artifacts using the wagon-webdav plugin. I originally thought it was a client problem with the plugin since no errors were showing up in the Archiva logs until I did a tcpdump and found the exception sent from the Archiva server. I assumed all errors in Archiva would output a stack trace in the logs, but apparently this is not always the case. I've attached the HTTP session information showing the stack trace.

        Issue Links

          Activity

          Wendy Smoak added a comment -

          From WAGON-96, it looks like this happens on deploy. Can you please list the steps to reproduce this?

          James William Dumay added a comment -

          Issue has been fixed in Wagon. Its also worth noting that in the Jackrabbit based DavServlet in 1.1, exception handling is done correctly.


            People

            • Assignee:
              Unassigned
              Reporter:
              Erik R. Jensen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: