Archiva
  1. Archiva
  2. MRM-630

http 502 proxy error with browse button after 2 days running

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.0.1
    • Component/s: browser
    • Labels:
      None
    • Number of attachments :
      1

      Description

      I have to restart archiva every one or two days; if not, archiva becomes unstable :

      • main page and admin section are accessible and work fine,
      • archiva/browse/ function is dead, giving in navigator :
        Proxy Error
        The proxy server received an invalid response from an upstream server.
        The proxy server could not handle the request /GET /archiva/browse
        <http://archiva.nuxeo.org/archiva/browse>/.
        Reason: Error reading from remote server

      Restarting archiva immediately solves the problem.

      I didn't find relevant logs, I guess

        Issue Links

          Activity

          jameswdumay added a comment -

          Thread dump of this problem

          Maria Odea Ching added a comment -

          Could this be the culprit? http://www.jpox.org/servlet/jira/browse/CORE-3408

          Archiva is using jpox 1.1.7 and it seems this is also affected by the locking issue.. (please see the thread link in the jpox jira).

          jameswdumay added a comment -

          Good find Maria.

          I've removed jpox 1.1.7 from our server and replaced it with the 1.1.9 version (which contains the above issue and another deadlocking issue) for a quick test. Ill write up on this issue how it went.

          Also, if we were to upgrade jpox to 1.1.9, it does not appear to be in the maven central repo.

          Thomas Marti added a comment - - edited

          The JPOX project stopped using Ibiblio because of its inconvenient upload process.
          We have our own repo at http://www.jpox.org/downloads/maven/

          jameswdumay added a comment -

          I can confirm upgrading to jpox 1.1.9 fixes the 502 problem

          Maria Odea Ching added a comment -

          Thanks James!

          Upgraded archiva trunk from jpox 1.1.7 to 1.1.9 (-r609485).
          Is it safe to close this issue now?

          jameswdumay added a comment - - edited

          I think so. Could we organise a point release with this fix?


            People

            • Assignee:
              Maria Odea Ching
              Reporter:
              Julien CARSIQUE
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: