Archiva
  1. Archiva
  2. MRM-329

The Reports link gives an HTTP 500

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.0-alpha-1
    • Fix Version/s: 1.0-beta-1
    • Component/s: reporting
    • Labels:
      None
    • Number of attachments :
      7

      Description

      Clicking the Reports link in the side navigation menu displays the following (edited/snipped stacktrace):
      HTTP ERROR: 500
      RequestURI=/admin/reports.action
      Caused by: javax.el.PropertyNotFoundException: The class 'org.apache.maven.archiva.reporting.artifact.OldArtifactReport' does not have the property 'groupId'.
      at javax.el.BeanELResolver.getBeanProperty(BeanELResolver.java:574)
      at javax.el.BeanELResolver.getValue(BeanELResolver.java:280)
      at javax.el.CompositeELResolver.getValue(CompositeELResolver.java:143)
      at com.sun.el.parser.AstValue.getValue(AstValue.java:118)
      at com.sun.el.ValueExpressionImpl.getValue(ValueExpressionImpl.java:192)
      at org.apache.jasper.runtime.PageContextImpl.evaluateExpression(PageContextImpl.java:974)
      at org.apache.jsp.WEB_002dINF.jsp.reports.reports_jsp._jspx_meth_c_forEach_0(org.apache.jsp.WEB_002dINF.jsp.reports.reports_jsp:143)
      at org.apache.jsp.WEB_002dINF.jsp.reports.reports_jsp._jspService(org.apache.jsp.WEB_002dINF.jsp.reports.reports_jsp:85)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:111)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:373)

      1. MRM-329.patch
        64 kB
        Teodoro Cue Jr.
      2. MRM-329-archiva-database-20070725.patch
        4 kB
        Teodoro Cue Jr.
      3. MRM-329-archiva-database-20070801.patch
        11 kB
        Teodoro Cue Jr.
      4. MRM-329-archiva-model-20070727.patch
        0.9 kB
        Teodoro Cue Jr.
      5. MRM-329-archiva-model-20070801.patch
        2 kB
        Teodoro Cue Jr.
      6. MRM-329-archiva-webapp-20070725.patch
        14 kB
        Teodoro Cue Jr.
      7. MRM-329-archiva-webapp-20070801.patch
        36 kB
        Teodoro Cue Jr.

        Issue Links

          Activity

          Maria Odea Ching added a comment -

          Thanks for the patch Teody.. the reports definitely looks better now

          I agree with Brett's comments, especially the constraints/fields being grouped together in one form. It'll be easier for the user to use.
          Below are some additional comments:

          • Can the version link in the reports be removed? I think it would always display the 'Unable to find...' error message whenever you click it since the project model is never added to the database once it is found to be invalid
          • Could you provide some unit tests for these?
          • And lastly, what about the reports not being accessible to only those users with admin roles? Should that be included here? Or is that a separate issue?

          Btw, I didn't see the tanuki WrapperSimpleApp started when I executed the reports

          Joakim Erdfelt added a comment -

          Patches look good.

          Great work Teody!

          Patches applied in revision 562233.

          Teodoro Cue Jr. added a comment -

          Hi Guys,

          I've attached the latest patch with changes in my email yesterday on the dev mailing list.
          Patch is now formatted with Brett's comments taken into consideration. Thanks for the info Brett!

          Changes:
          -Taken out Artifact search

          -Taken out Version link
          -Repository list now a drop down

          -Consolidated all the fields into 1 form

          -Dropped the last 3 columns from the table

          -Unit tests for all the constraints

          Lacking:
          -Unit tests for the actions and the model (can someone help me out as to how to test the action? how do we inject the dao from the test environment?)
          -Form validation (especially the rowCount, which needs a positive number)
          -Profile regarding licensing of JasperReports discussed in the dev mailing list

          Comments are always welcome!

          Brett Porter added a comment -

          couple of tweaks I'd make:

          • if you enter org.apache, look for org.apache*
          • add "(All Repositories)" as the text on the default repository id.
          Brett Porter added a comment -

          applied, thanks!


            People

            • Assignee:
              Teodoro Cue Jr.
              Reporter:
              Nap Ramirez
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: