Archiva
  1. Archiva
  2. MRM-1467

Archiva does not start up on Solaris 64-bit.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.3.4
    • Fix Version/s: 1.3.5
    • Component/s: None
    • Labels:
      None
    • Environment:
      SunOS unknown 5.10 Generic_138889-02 i86pc i386 i86pc
    • Number of attachments :
      0

      Description

      Attempting to launch causes causes error:
      $ ./apache-archiva-1.3.4/bin/archiva console

      Bad string
      Bad string
      Bad string
      Bad string
      Unable to locate any of the following binaries:
      /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---32
      /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---64
      /export/home/astine/apache-archiva-1.3.4/bin/./wrapper

      necessary files appear to be missing or misnamed.

        Activity

        Brett Porter added a comment -

        what is the output of the following commands for you?

        uname -s
        uname -p
        uname -m

        Can you run the start command using "bash -x ./archiva console", and attach the log?

        I can see that maybe it wouldn't understand "i86pc". I'm not sure why the i386 and SunOS are not being understood though.

        Andrew Stine added a comment -

        uname -s: SunOS
        uname -p: i386
        uname -m: i86pc
        uname -a: SunOS unknown 5.10 Generic_138889-02 i86pc i386 i86pc

        Log:
        + APP_NAME=archiva
        + APP_LONG_NAME='Apache Archiva'
        + '[' X = X ']'
        + ARCHIVA_BASE=..
        + WRAPPER_CMD=./wrapper
        + WRAPPER_CONF=../conf/wrapper.conf
        + '[' '!' -f ../conf/wrapper.conf ']'
        + PRIORITY=
        + PIDDIR=../logs
        + case $0 in
        ++ pwd
        + PWD=/export/home/astine/apache-archiva-1.3.4/bin
        + SCRIPT=/export/home/astine/apache-archiva-1.3.4/bin/./archiva
        + CHANGED=true
        + '[' Xtrue '!=' X ']'
        ++ echo /export/home/astine/apache-archiva-1.3.4/bin/./archiva
        ++ sed -e 's; ;:;g'
        + SAFESCRIPT=/export/home/astine/apache-archiva-1.3.4/bin/./archiva
        ++ echo /export/home/astine/apache-archiva-1.3.4/bin/./archiva
        ++ sed -e 's;/; ;g'
        + TOKENS=' export home astine apache-archiva-1.3.4 bin . archiva'
        + REALPATH=
        + for C in '$TOKENS'
        ++ echo export
        ++ sed -e 's;:; ;g'
        + C=export
        + REALPATH=/export
        + '[' -h /export ']'
        + for C in '$TOKENS'
        ++ echo home
        ++ sed -e 's;:; ;g'
        + C=home
        + REALPATH=/export/home
        + '[' -h /export/home ']'
        + for C in '$TOKENS'
        ++ echo astine
        ++ sed -e 's;:; ;g'
        + C=astine
        + REALPATH=/export/home/astine
        + '[' -h /export/home/astine ']'
        + for C in '$TOKENS'
        ++ echo apache-archiva-1.3.4
        ++ sed -e 's;:; ;g'
        + C=apache-archiva-1.3.4
        + REALPATH=/export/home/astine/apache-archiva-1.3.4
        + '[' -h /export/home/astine/apache-archiva-1.3.4 ']'
        + for C in '$TOKENS'
        ++ echo bin
        ++ sed -e 's;:; ;g'
        + C=bin
        + REALPATH=/export/home/astine/apache-archiva-1.3.4/bin
        + '[' -h /export/home/astine/apache-archiva-1.3.4/bin ']'
        + for C in '$TOKENS'
        ++ echo .
        ++ sed -e 's;:; ;g'
        + C=.
        + REALPATH=/export/home/astine/apache-archiva-1.3.4/bin/.
        + '[' -h /export/home/astine/apache-archiva-1.3.4/bin/. ']'
        + for C in '$TOKENS'
        ++ echo archiva
        ++ sed -e 's;:; ;g'
        + C=archiva
        + REALPATH=/export/home/astine/apache-archiva-1.3.4/bin/./archiva
        + '[' -h /export/home/astine/apache-archiva-1.3.4/bin/./archiva ']'
        + '[' /export/home/astine/apache-archiva-1.3.4/bin/./archiva = /export/home/astine/apache-archiva-1.3.4/bin/./archiva ']'
        + CHANGED=
        + '[' X '!=' X ']'
        ++ dirname /export/home/astine/apache-archiva-1.3.4/bin/./archiva
        + cd /export/home/astine/apache-archiva-1.3.4/bin/.
        ++ pwd
        + REALDIR=/export/home/astine/apache-archiva-1.3.4/bin
        ++ echo ../logs
        ++ cut -c1,1
        + FIRST_CHAR=.
        + '[' . '!=' / ']'
        + PIDDIR=/export/home/astine/apache-archiva-1.3.4/bin/../logs
        ++ echo ./wrapper
        ++ cut -c1,1
        + FIRST_CHAR=.
        + '[' . '!=' / ']'
        + WRAPPER_CMD=/export/home/astine/apache-archiva-1.3.4/bin/./wrapper
        ++ echo ../conf/wrapper.conf
        ++ cut -c1,1
        + FIRST_CHAR=.
        + '[' . '!=' / ']'
        + WRAPPER_CONF=/export/home/astine/apache-archiva-1.3.4/bin/../conf/wrapper.conf
        + ANCHORFILE=/export/home/astine/apache-archiva-1.3.4/bin/../logs/archiva.anchor
        + PIDFILE=/export/home/astine/apache-archiva-1.3.4/bin/../logs/archiva.pid
        + LOCKDIR=/var/lock/subsys
        + LOCKFILE=/var/lock/subsys/archiva
        + pid=
        + PSEXE=/usr/bin/ps
        + '[' '!' -x /usr/bin/ps ']'
        ++ uname -s
        ++ tr '[:upper:]' '[:lower:]'
        ++ tr -d '[:blank:]'
        Bad string
        Bad string
        + DIST_OS=
        + case "$DIST_OS" in
        ++ uname -p
        ++ tr -d '[:blank:]'
        ++ tr '[:upper:]' '[:lower:]'
        Bad string
        Bad string
        + DIST_ARCH=
        + '[' '' = unknown ']'
        + case "$DIST_ARCH" in
        + WRAPPER_TEST_CMD=/export/home/astine/apache-archiva-1.3.4/bin/./wrapper---32
        + '[' -x /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---32 ']'
        + '[' '' = macosx ']'
        + WRAPPER_TEST_CMD=/export/home/astine/apache-archiva-1.3.4/bin/./wrapper---64
        + '[' -x /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---64 ']'
        + '[' '!' -x /export/home/astine/apache-archiva-1.3.4/bin/./wrapper ']'
        + echo 'Unable to locate any of the following binaries:'
        Unable to locate any of the following binaries:
        + outputFile /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---32
        + '[' -f /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---32 ']'
        + echo ' /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---32'
        /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---32
        + outputFile /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---64
        + '[' -f /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---64 ']'
        + echo ' /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---64'
        /export/home/astine/apache-archiva-1.3.4/bin/./wrapper---64
        + outputFile /export/home/astine/apache-archiva-1.3.4/bin/./wrapper
        + '[' -f /export/home/astine/apache-archiva-1.3.4/bin/./wrapper ']'
        + echo ' /export/home/astine/apache-archiva-1.3.4/bin/./wrapper'
        /export/home/astine/apache-archiva-1.3.4/bin/./wrapper
        + exit 1

        Andrew Stine added a comment - - edited

        FYI, I'm having a similar problem on Linux machines (I've tried two.)

        Running it on linux produces a similar output:
        /home/illuminati/apache-archiva-1.3.4/bin/./wrapper-linux-intel(r)core(tm)2cpu4300@1.80ghz-32
        /home/illuminati/apache-archiva-1.3.4/bin/./wrapper-linux-intel(r)core(tm)2cpu4300@1.80ghz-64
        /home/illuminati/apache-archiva-1.3.4/bin/./wrapper

        This leads me to believe that the problem is on my end, but I can't figure what I'm doing wrong.

        Brett Porter added a comment -

        I haven't seen anyone else report these, though I can't see how you'd have misconfigured it. On Solaris, it looks like the 'tr' command is the one not working, on Linux I'm not sure why uname would do that.

        You could workaround it by editing the archiva shell script to set the correct WRAPPER_CMD.

        Andrew Stine added a comment -

        I've isolated the problem to an issue with the solaris version of tr.

        TheIssue can be solved by using a different version of tr on solaris:

        http://binarycrusader.blogspot.com/2005/04/solaris-10-yet-another-development-tip.html

        Brett Porter added a comment -

        great!

        We should just need to patch the install docs then.

        how about the linux based issue? resolved too?

        Andrew Stine added a comment -

        On linux the problem is that 'uname -p' is returning values that the 'archiva' script isn't anticipating. It might be a system specific thing I'm not sure, but I worked around it by having it fallthrough to 'uname -m' when 'uname -p' returns an unexpected value.

        Maria Odea Ching added a comment - - edited

        Updated installation docs using standalone bundle with the issue on tr version in Solaris in 1.3.x branch -r1103608.

        Maria Odea Ching added a comment -

        Changes merged to trunk in -r1103611.


          People

          • Assignee:
            Maria Odea Ching
            Reporter:
            Andrew Stine
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: