Archiva
  1. Archiva
  2. MRM-1172

Invalid version validation error when uploading a jar with a four-part version number

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.1
    • Fix Version/s: 1.2.1
    • Component/s: Web Interface
    • Labels:
      None
    • Environment:
      Archiva 1.2.1-SNAPSHOT trunk r761865
    • Number of attachments :
      2

      Description

      Archiva will not allow you to upload an artifact with a version number in the format 2.5-r123456-proj-1.2.3

      We use this version number format to do internal releases of third-party artifacts.

      Deploying from the command line works, but the artifact upload form in Archiva will not accept this version number and displays "Invalid version".

      1. MRM-1172.patch
        0.7 kB
        jan ancajas
      2. MRM-1172-2.patch
        3 kB
        jan ancajas

        Issue Links

          Activity

            People

            • Assignee:
              Maria Odea Ching
              Reporter:
              Wendy Smoak
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: