Archiva
  1. Archiva
  2. MRM-1075

Error 500 when accessing repository url

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2
    • Labels:
      None
    • Number of attachments :
      0

      Description

      HTTP ERROR: 500

      INTERNAL_SERVER_ERROR

      RequestURI=/archiva/repository/sample/
      Caused by:

      java.lang.NullPointerException
      at org.codehaus.redback.integration.filter.authentication.HttpAuthenticator.authenticate(HttpAuthenticator.java:64)
      at org.codehaus.redback.integration.filter.authentication.basic.HttpBasicAuthentication.getAuthenticationResult(HttpBasicAuthentication.java:85)
      at org.apache.maven.archiva.webdav.ArchivaDavSessionProvider.attachSession(ArchivaDavSessionProvider.java:66)
      at org.apache.maven.archiva.webdav.RepositoryServlet.service(RepositoryServlet.java:111)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
      at org.apache.struts2.dispatcher.FilterDispatcher.doFilter(FilterDispatcher.java:413)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:39)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.apache.struts2.dispatcher.ActionContextCleanUp.doFilter(ActionContextCleanUp.java:99)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
      at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:722)
      at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:404)
      at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
      at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
      at org.mortbay.jetty.Server.handle(Server.java:324)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
      at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:828)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
      at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
      at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)

      Looks like this is caused by the upgrade to Redback 1.2-beta-2. This doesn't occur in the Archiva 1.2-M1 release.

        Activity

        Maria Odea Ching added a comment -

        Fixed REDBACK-193 for the NPE. Need to upgrade Archiva's Redback to the latest in trunk or to 1.2-beta-3 when released.

        Maria Odea Ching added a comment -

        Verified as fixed after the upgrade to 1.2-SNAPSHOT

        Thomas added a comment - - edited

        new error MRM-1237


          People

          • Assignee:
            Maria Odea Ching
            Reporter:
            Maria Odea Ching
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: