Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.2
    • Fix Version/s: 2.3
    • Component/s: scm
    • Labels:
      None
    • Environment:
      N/A
    • Patch Submitted:
      Yes
    • Number of attachments :
      1

      Description

      The Jazz SCM plugin requires SCM translation of the URL's in the POM.
      This patch addresses that.

      Note. This issue will ultimately depend on mavn-scm 1.7 being released, as that version will include the maven-scm-providers-jazz module.

        Issue Links

          Activity

          Chris Graham added a comment -

          This issue depends upon SCM-670, the Jazz implementation.

          Olivier Lamy added a comment -

          fixed r1329108
          Thanks!

          Robert Scholte added a comment -

          I've added a unit-test for the JazzScmTranslator in r1334383, please verify.
          According to the test it doesn't make sense to specify a different tagBase

          Mark Struberg added a comment -

          Hi!

          When hacking the similar stuff for GitScmTranslator and Hg I found out that the JazzScmTranslator still has the HEAD logic from CVS in it. Jazz folks, are you sure that Jazz also has such a special HEAD thingy? The HEAD in CVS is similar to the SVN trunk! It just denotes that you are on the CVS main route. I guess this is a copy & paste leftover...

          Robert Scholte added a comment - - edited

          Mark, I think this is caused by http://maven.apache.org/ref/3.0.4/maven-model/xref/org/apache/maven/model/Scm.html#64
          The tag has the "HEAD" as default value, which causes the trouble. And this includes that you probably can't set the tag to HEAD if you want... (although it's a very small chance you want this )

          Mark Struberg added a comment -

          ouch ^^
          good catch, you are digging pretty deep
          I assume this is coming from the original code which was mainly made for CVS back then. We need to check the history...

          Chris Graham added a comment -

          No, it is exactly what I need.

          Let me explain a bit further.

          1. First and foremost. I was a little confused by it. I am not entirely certain what this value is for, and given the 5-6 years I've been using maven, I've never seen it used, nor could I find it well docuemented either. However, what digging I did, the only examples (and tests, from memory) I only ever saw HEAD.

          2. Not having the tag present is what I require.

          Let me dig into that one for you.

          In Jazz SCM terms, a tag is Snapshot (see the extensive doco I put in the SCM provider - working with the release plugin: http://maven.apache.org/scm/maven-scm-providers/maven-scm-provider-jazz/releases.html ). The underlying CLI tool, scm(.exe) is what is used for all Jazz SCM interactions.

          The tag operation maps to a "scm create snapshot" operation.

          We can not, at this point in time, though the next release V4 due in the next few weeks from what I understand, checkout (load in Jazz SCM terms) we can not directly check out this tag. We need to create (effectively an intermidiate) workspace from the tag/snapshot.

          It is this repository workspace that is loaded locally and used to execute the release:perform. ie the same as the svn co .../tag/... command.

          So, we are then left with how to specify how to checkout/load the tag/snapshot. ie, the repository workspace.

          Yes, we end up with lots of repository workspaces on the server - one for each release performed. These can be deleted. And can also be recreated from the snapshot at any time.

          So, effectively, we are at the HEAD of the repository workspace (the one that was created from the tag/snapshot). So in this case, we're at the head of the tag (aka repository workspace).

          And this, is why the <tag> item in the section section is returned as null - we don't need it.

          And this is correct.

          Does this make sense?


            People

            • Assignee:
              Olivier Lamy
              Reporter:
              Chris Graham
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: