Maven Release Plugin
  1. Maven Release Plugin
  2. MRELEASE-727

release plugin uses wrong checkout directory

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.2.2
    • Fix Version/s: 2.3
    • Component/s: perform
    • Labels:
      None
    • Environment:
      mvn 3.0.3
    • Number of attachments :
      4

      Description

      When performing a release build on a multi module project, the plugin uses a wrong checkout directory and therefore is unable to perform the release.
      I tested this with both version 2.2 and 2.2.2

      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.2.2:perform (default-cli) on project test_multi_parent: Error executing Maven. Working directory "/Users/domi/work/ws/sts_0/test_multi_parent/target/checkout/test_multi_parent/test_multi_parent" does not exist! -> [Help 1]

      We use flat project structure (where parent and modul project are in the same directory)
      The SVN Repo looks like this:

      .../svnrepos/KUQ/trunk/test_multi_parent
      .../svnrepos/KUQ/trunk/test_multi_module1

      I'll attache a minimal test project to reproduce it and a file containing the whole log output for release:prepare and release:perform

      To reproduce the problem:

      • adjust the SVN paths in the pom.xml
      • checkin to SVN
      • release:prepare
      • release:perform -Dgoals=install

        Issue Links

          Activity

          Mark Struberg added a comment -

          Hi folks!

          Could you please try the attached patch?
          This version works with GIT and hg again and should also do for SVN. txs!

          Mark Struberg added a comment -

          fix committed in r1332385.

          I'll now only do the pom scan if the SCM itself doesn't offer a relativePath.

          Mark Struberg added a comment -

          should now finally be fixed. Please reopen if there is still a scenario left which we didn't think about carefully enough.

          Sylvain LAURENT added a comment -

          It still does not work with CVS : only the current project is checked out directly in "target/checkout" (so, the tagged pom.xml is created in target/checkout). And then mvn complains that the directory target/checkout/parentproject does not exist.

          I cannot reopen this issue, it seems I don't have the rights in JIRA... Should I create a new issue ?

          Mark Struberg added a comment -

          yes, please create a new one. Do you folks really still use CVS? CVS is dead since 2006 ^^


            People

            • Assignee:
              Olivier Lamy
              Reporter:
              Dominik Bartholdi
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: