Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Incomplete
    • Affects Version/s: 2.2, 2.2.1
    • Fix Version/s: None
    • Component/s: perform
    • Labels:
      None
    • Environment:
      accurev scm provider
    • Number of attachments :
      1

      Description

      During perform, the fix for MRELEASE-457 changes the checkout directory by appending the checkout path, later the release manager appends it again in determineWorkingDirectory(). As a result maven cannot find the checked out project.
      Please see attached log file with -X output, specifically line 1541 that shows the correct project path, however, when it comes to running the deploy command, it appends project path again as indicated by line 1553.

        Activity

        Andrey Taranov added a comment -

        So I'm sequentially trying all versions:

        • maven-release-plugin:2.0 works OK
        • maven-release-plugin:2.1 works OK
        • maven-release-plugin:2.2 doesn't work
        Andrey Taranov added a comment -

        Here is a log fragment from version 2.1 release goal:

        C:\dev\spikes-local\mvnrelease-flat\parent>mvn release:perform -Dmaven.scm.provider.cvs.implementation=cvs_native -DcommitByProject=true
        [INFO] Scanning for projects...
        [INFO] ------------------------------------------------------------------------
        [INFO] Reactor Build Order:
        [INFO]
        [INFO] parent
        [INFO] first-jar
        [INFO] second-jar
        [INFO]
        [INFO] ------------------------------------------------------------------------
        [INFO] Building parent 1.10-SNAPSHOT
        [INFO] ------------------------------------------------------------------------
        [INFO]
        [INFO] --- maven-release-plugin:2.1:perform (default-cli) @ parent ---
        [INFO] Checking out the project to perform the release ...
        [INFO] Executing: cmd.exe /X /C "cvs -z3 -f -d :local:d:\cvsroot -q checkout -r parent-1_9 -d checkout mvnrelease-flat"
        [INFO] Working directory: C:\dev\spikes-local\mvnrelease-flat\parent\target
        [INFO] Executing goals 'deploy'...
        
        Andrey Taranov added a comment -

        Here is the log for version 2.2 release goal.

        Notice the second warning:

        Base directory is a file. Using base directory as POM location.

        This was not present in version 2.1.

        Also notice the error message:

        Working directory "C:\dev\spikes-local\mvnrelease-flat\parent\target\checkout\parent\parent" does not exist!

        The last directory is duplicated!

        C:\dev\spikes-local\mvnrelease-flat\parent>mvn release:perform -Dmaven.scm.provider.cvs.implementation=cvs_native -DcommitByProject=true
        [INFO] Scanning for projects...
        [INFO] ------------------------------------------------------------------------
        [INFO] Reactor Build Order:
        [INFO]
        [INFO] parent
        [INFO] first-jar
        [INFO] second-jar
        [INFO]
        [INFO] ------------------------------------------------------------------------
        [INFO] Building parent 1.11-SNAPSHOT
        [INFO] ------------------------------------------------------------------------
        [INFO]
        [INFO] --- maven-release-plugin:2.2:perform (default-cli) @ parent ---
        [INFO] Checking out the project to perform the release ...
        [INFO] Executing: cmd.exe /X /C "cvs -z3 -f -d :local:d:\cvsroot -q checkout -r parent-1_10-SNAPSHOT -d checkout mvnrelease-flat"
        [INFO] Working directory: C:\dev\spikes-local\mvnrelease-flat\parent\target
        [INFO] Invoking perform goals in directory C:\dev\spikes-local\mvnrelease-flat\parent\target\checkout\parent
        [INFO] Executing goals 'deploy'...
        [WARNING] Base directory is a file. Using base directory as POM location.
        [WARNING] Maven will be executed in interactive mode, but no input stream has been configured for this MavenInvoker instance.
        [INFO] ------------------------------------------------------------------------
        [INFO] Reactor Summary:
        [INFO]
        [INFO] parent ............................................ FAILURE [2.300s]
        [INFO] first-jar ......................................... SKIPPED
        [INFO] second-jar ........................................ SKIPPED
        [INFO] ------------------------------------------------------------------------
        [INFO] BUILD FAILURE
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 2.572s
        [INFO] Finished at: Sat May 05 22:59:16 GMT+04:00 2012
        [INFO] Final Memory: 5M/15M
        [INFO] ------------------------------------------------------------------------
        [ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.2:perform (default-cli) on project parent: Error executing Maven. Working directory "C:\dev\spikes-local\mvnrelease-flat\parent\target\checkout\parent\parent" does not exist! -> [Help 1]
        [ERROR]
        [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
        [ERROR] Re-run Maven using the -X switch to enable full debug logging.
        [ERROR]
        [ERROR] For more information about the errors and possible solutions, please read the following articles:
        [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
        
        Mark Struberg added a comment -

        This could be a duplicate of MRELEASE-727 , wdyt?

        Robert Scholte added a comment -

        I see no reply on Marks question, so I'll close this as incomplete, hoping it's indeed a duplicate.


          People

          • Assignee:
            Unassigned
            Reporter:
            Vadim Tsing
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: