Maven Reactor Plugin (RETIRED)
  1. Maven Reactor Plugin (RETIRED)
  2. MREACTOR-9

Embedded error: roots differ error on simple project

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.0
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      cygwin
    • Number of attachments :
      1

      Description

      Unpack the attached project, go to the root-pom directory and do mvn reactor:make -Dmake.artifacts=B-api :

      $ mvn reactor:make -Dmake.artifacts=B-api
      [INFO] Scanning for projects...
      [INFO] Reactor build order: 
      [INFO]   myProject
      [INFO]   A api
      [INFO]   A impl
      [INFO]   A-modules
      [INFO]   B api
      [INFO]   B impl
      [INFO]   B-modules
      [INFO]   myProject-modules
      [INFO] Searching repository for plugin with prefix: 'reactor'.
      [INFO] ------------------------------------------------------------------------
      [INFO] Building myProject
      [INFO]    task-segment: [reactor:make] (aggregator-style)
      [INFO] ------------------------------------------------------------------------
      [INFO] [reactor:make]
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Problem generating dependency tree
      
      Embedded error: Roots differ
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 3 seconds
      [INFO] Finished at: Tue Sep 30 09:18:16 CEST 2008
      [INFO] Final Memory: 7M/13M
      [INFO] ------------------------------------------------------------------------
      
      

      or go to the modules directory and do make.folders=B/api :

      $ mvn reactor:make -Dmake.folders=B/api
      [INFO] Scanning for projects...
      [INFO] Reactor build order: 
      [INFO]   A api
      [INFO]   A impl
      [INFO]   A-modules
      [INFO]   B api
      [INFO]   B impl
      [INFO]   B-modules
      [INFO]   myProject-modules
      [INFO] Searching repository for plugin with prefix: 'reactor'.
      [INFO] ------------------------------------------------------------------------
      [INFO] Building myProject-modules
      [INFO]    task-segment: [reactor:make] (aggregator-style)
      [INFO] ------------------------------------------------------------------------
      [INFO] [reactor:make]
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] No folders matched: B/api
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 4 seconds
      [INFO] Finished at: Tue Sep 30 09:16:14 CEST 2008
      [INFO] Final Memory: 7M/14M
      [INFO] ------------------------------------------------------------------------
      

        Activity

        Jorg Heymans added a comment -

        actually, there might be something environment specific here that is causing the exception. When i execute the first command again, but now from plain DOS i get something else:

        D:\tmp\reactor-bug\root-pom>mvn reactor:make -Dmake.artifacts=B-api
        [INFO] Scanning for projects...
        [INFO] Reactor build order:
        [INFO]   myProject
        [INFO]   A api
        [INFO]   A impl
        [INFO]   A-modules
        [INFO]   B api
        [INFO]   B impl
        [INFO]   B-modules
        [INFO]   myProject-modules
        [INFO] Searching repository for plugin with prefix: 'reactor'.
        [INFO] ------------------------------------------------------------------------
        [INFO] Building myProject
        [INFO]    task-segment: [reactor:make] (aggregator-style)
        [INFO] ------------------------------------------------------------------------
        [INFO] [reactor:make]
        [INFO] Executing: cmd.exe /X /C "D:\tools\maven2\bin\mvn.bat -B -N -r -D maven.reactor.includes=..\modules\B\api\pom.xml install"
        [INFO] Scanning for projects...
        [INFO] ------------------------------------------------------------------------
        [INFO] Building Maven Default Project
        [INFO]    task-segment: [install]
        [INFO] ------------------------------------------------------------------------
        [INFO] ------------------------------------------------------------------------
        [ERROR] BUILD ERROR
        [INFO] ------------------------------------------------------------------------
        [INFO] Cannot execute mojo: resources. It requires a project with an existing pom.xml, but the build is not using one.
        [INFO] ------------------------------------------------------------------------
        [INFO] For more information, run Maven with the -e switch
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 1 second
        [INFO] Finished at: Tue Sep 30 09:20:15 CEST 2008
        

        Now from the modules directory, when i do mvn reactor:make -Dmake.artifacts=B-api and mvn reactor:make -Dmake.folders=B/api both work !

        Dan Fabulich added a comment -

        Yes, it seems very likely that cygwin is causing the problem. The "plain DOS" results ("Cannot execute mojo: resources") are what I see on my machine also, and is what I would expect due to MREACTOR-1. I'll try to repro the problem on cygwin.

        Juan Cruz Nores added a comment -

        I'm having the same problem on OSX, so I'm not so sure that it's environment-specific:

        + Error stacktraces are turned on.
        [INFO] Scanning for projects...
        [INFO] Reactor build order: 
        [INFO]   myProject
        [INFO]   A api
        [INFO]   A impl
        [INFO]   A-modules
        [INFO]   B api
        [INFO]   B impl
        [INFO]   B-modules
        [INFO]   myProject-modules
        [INFO] Searching repository for plugin with prefix: 'reactor'.
        [INFO] ------------------------------------------------------------------------
        [INFO] Building myProject
        [INFO]    task-segment: [reactor:make] (aggregator-style)
        [INFO] ------------------------------------------------------------------------
        [INFO] [reactor:make {execution: default-cli}]
        [INFO] Executing: /bin/sh -c cd /Users/juancn/Downloads/reactor-bug/root-pom && /usr/share/java/maven-2.2.0/bin/mvn -B -N -r -D maven.reactor.includes=../modules/B/api/pom.xml install
        [INFO] Scanning for projects...
        [INFO] ------------------------------------------------------------------------
        [INFO] Building Maven Default Project
        [INFO]    task-segment: [install]
        [INFO] ------------------------------------------------------------------------
        [INFO] ------------------------------------------------------------------------
        [ERROR] BUILD ERROR
        [INFO] ------------------------------------------------------------------------
        [INFO] Cannot execute mojo: resources. It requires a project with an existing pom.xml, but the build is not using one.
        [INFO] ------------------------------------------------------------------------
        [INFO] For more information, run Maven with the -e switch
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: < 1 second
        [INFO] Finished at: Tue Oct 19 19:33:15 BRST 2010
        [INFO] Final Memory: 6M/81M
        [INFO] ------------------------------------------------------------------------
        [INFO] ------------------------------------------------------------------------
        [ERROR] BUILD ERROR
        [INFO] ------------------------------------------------------------------------
        [INFO] Maven build failed: Exit code was 1
        
        [INFO] ------------------------------------------------------------------------
        [INFO] Trace
        org.apache.maven.lifecycle.LifecycleExecutionException: Maven build failed: Exit code was 1
                at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:703)
                at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:553)
                at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:523)
                at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:371)
                at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:268)
                at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)
                at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
                at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
                at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
                at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:41)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                at java.lang.reflect.Method.invoke(Method.java:597)
                at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
                at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
                at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
                at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
        Caused by: org.apache.maven.plugin.reactor.SimpleInvoker$InvokerExecutionException: Maven build failed: Exit code was 1
                at org.apache.maven.plugin.reactor.SimpleInvoker.runReactor(SimpleInvoker.java:77)
                at org.apache.maven.plugin.reactor.MakeMojo.execute(MakeMojo.java:184)
                at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:483)
                at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:678)
                ... 17 more
        Caused by: org.apache.maven.plugin.reactor.SimpleInvoker$InvokerExecutionException: Exit code was 1
                at org.apache.maven.plugin.reactor.SimpleInvoker.runReactor(SimpleInvoker.java:73)
                ... 20 more
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 3 seconds
        [INFO] Finished at: Tue Oct 19 19:33:15 BRST 2010
        [INFO] Final Memory: 12M/81M
        [INFO] ------------------------------------------------------------------------
        
        Karl-Heinz Marbaise added a comment -

        This plugin is retired. So all issue are being closed.

        Karl-Heinz Marbaise made changes -
        Field Original Value New Value
        Resolution Won't Fix [ 2 ]
        Status Open [ 1 ] Closed [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Jorg Heymans
          • Votes:
            4 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: