Maven 1.x XDoc Plugin
  1. Maven 1.x XDoc Plugin
  2. MPXDOC-47

Ampersands in navigation.xml being escaped twice during xml parsing

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.10
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Within my Maven navigation.xml i would like to include a URL that includes parameter (&s). So if I place & or & after the xml is parsed the URL that is generated in the html files have '&' instead of an '&'
      I have the xml encoding ISO-8859-1

        Issue Links

          Activity

          Brett Porter added a comment -

          works for me! Can you confirm it is still present in beta-10?

          dion gillard added a comment -

          Noone's come back on trying to reproduce this.

          Julien Kirch added a comment -

          I successfully (ahem) reproduced the bug : the amp should be in the link part of the navigation file and not in the menu part.

          dion gillard added a comment -

          Can you provide a sample?

          I'll happily reopen this issue if you do.

          Julien Kirch added a comment -

          Please reopen it, cause it still occurs and here's a sample (as the issue is closed I can't attach a file).

          Note than solving this issue will probably cause the way the issue MPXDOC-92 is fixed.

          #######
          <?xml version="1.0" encoding="ISO-8859-1"?>
          <project name="Foo">

          <title>Bar</title>
          <body>

          <links>
          <item
          name="http://foo&bar"
          href="http://foo&bar"
          />
          <item
          name="Maven xdoc plugin changelog"
          href="http://jira.codehaus.org/secure/BrowseProject.jspa?id=10355&report=changelog"
          />
          </links>

          </body>
          </project>
          #######

          Julien Kirch added a comment -

          In the above comment "Note than solving this issue will probably cause the way the issue MPXDOC-92 is fixed /to become invalid/."

          Lukas Theussl added a comment -

          A patch that fixes the double-escaping of character entities in navigation links and titles, document titles and sub/sections (see MPXDOC-133). It needs modification for i18n.

          Lukas Theussl added a comment -

          Patch applied.


            People

            • Assignee:
              Lukas Theussl
              Reporter:
              Andrew Mace
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: