Maven 1.x XDoc Plugin
  1. Maven 1.x XDoc Plugin
  2. MPXDOC-200

[m1.1-RC1 Oct06] maven-xdoc-plugin-1.10.1-SNAPSHOT fails under JDK 6

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.10.1
    • Labels:
      None
    • Environment:
      java version "1.6.0-beta2"
      Java(TM) SE Runtime Environment (build 1.6.0-beta2-b86)
      Java HotSpot(TM) Client VM (build 1.6.0-beta2-b86, mixed mode, sharing)
      Win 2K
      Maven 1.1 RC 1 from Oct 2006
    • Number of attachments :
      0

      Description

      Hi

      Issue discussed on http://www.nabble.com/-m1.1-rc1--javadoc-does-not-generate-anything...-tf2220969.html

      Here is the log:

      xdoc:init:
      [echo] Generates the directory structure required for xdocs

      xdoc:i18n-validation:
      [echo] Validation of the locale entries

      BUILD FAILED
      File...... file:/C:/Documents and Settings/xhensevb/.maven/cache/maven-xdoc-plugin-1.10.1-SNAPSHOT/plugin.jelly
      Element... j:arg
      Line...... 666
      Column.... 70
      [Ljava.lang.Object;
      Total time : 1 minutes 9 seconds
      Finished at : 12 October 2006 13:54:00 BST

      ---------------

      I though that the issue may be related to generics and calling this invokeStatic on java.util.Arrays
      but this seems to work when I try at home with JDK 1.5.08 however, I'm having trouble with JDK 6-b2
      May be the interface has changed or one cannot use the following jelly code:

      <j:invokeStatic method="getAvailableLocales" className="java.util.Locale" var="availableLocales"/>
      <j:invokeStatic className="java.util.Arrays" method="asList" var="availableLocalesAsList">
      <j:arg value="$

      {availableLocales}

      " type="[Ljava.lang.Object;"/>
      </j:invokeStatic>

      I have checked the API for JDK6 and it seems to be the same...

      A simple maven site or maven multiproject:site under JDK 6 should confirm the issue, works fine under 1.5

      Definitely something around this "asList" call...

      Benoit

        Activity

        Lukas Theussl added a comment -

        I can reproduce this with jdk 1.6.0-beta2 on Linux, but not with java 5, so I guess it's a VM issue, maybe related to [1] but I'm not sure.

        [1] http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6468404

        Shinobu Kawai added a comment -

        This is due to a jelly bug [1] due to a change in the java6 ClassLoader implementation [2].

        [1] https://issues.apache.org/jira/browse/JELLY-274
        [2] http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6446627

        Shinobu Kawai added a comment -

        I applied a workaround to SVN, but looks like I don't have permission to resolve this bug...

        Shinobu Kawai added a comment -

        Resolved!


          People

          • Assignee:
            Shinobu Kawai
            Reporter:
            Benoit Xhenseval
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: