Maven 1.x XDoc Plugin
  1. Maven 1.x XDoc Plugin
  2. MPXDOC-174

Unclear error message when <currentVersion/> in the <project> section of the project.xml file not defined.

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.1
    • Fix Version/s: 1.10
    • Labels:
      None
    • Environment:
      Maven 1.1Beta, Win2k.
    • Number of attachments :
      0

      Description

      Unclear error message when <currentVersion/> in the <project> section of the project.xml file not defined.

      xdoc:jelly-transform:
      About to use JSL stylesheet
      file:/.../.maven/cache/maven-xdoc-plugin-1.9.1/plugin-resources/site.jsl
      [echo] en
      [echo] The current Locale is the default one
      [echo] Scanning 'D:\...\target\generated-xdocs'...
      [echo] Generating D:/.../target/docs/checkstyle-report.html from D:\...\target\generated-xdocs\checkstyle-report.xml
      BUILD FAILED File...... D:\...\.maven\cache\maven-xdoc-plugin-1.9.1\plugin.jelly
      Element... j:include
      Line...... 479
      Column.... 58
      file:/D:/.../.maven/cache/maven-xdoc-plugin-1.9.1/plugin-resources/site.jsl:33:17: <jsl:stylesheet>
      file:/D:/.../.maven/cache/maven-xdoc-plugin-1.9.1/plugin-resources/site.jsl:146:57: <jsl:applyTemplates>
      file:/D:/.../.maven/cache/maven-xdoc-plugin-1.9.1/plugin-resources/site.jsl:230:105: <maven:property> You must define an attribute called 'defaultValue' for this tag.
      Total time : 55 seconds
      Finished at : Saturday, August 13, 2005 9:46:36 AM EDT

        Activity

        Davy Toch added a comment -

        It would already be an improvement if the Maven core would validate the POM by default. This way an invalid POM would be detected at the start and would avoid error messages generated by called plugin goals that aren't always helpful.

        However the current problem is that the XSD isn't final yet and apparently still needs some minor modifications.

        Arnaud Heritier added a comment -

        The problem is that a lot of elements in the pom are optionals.
        These elements are used in some plugins and we don't wan't to force the user who don't want a plugin to define an used entry in the pom.
        I prefer to move this issue to the xdoc plugin (where the unclear message come from) but you can open a new task in the plugin-plugin (or in the pom-plugin) to add a new tag which helps plugins developpers to assert that a given entry in the pom is available.

        Lukas Theussl added a comment -

        Ok, but the point is that the error here comes from a call to the maven jelly tag library in site.jsl:
        <maven:property var="version" name="maven.xdoc.version" defaultValue="$

        {pom.currentVersion}

        "/>
        If we want a clearer error message, it should be done there generically.

        Arnaud Heritier added a comment -

        I fixed your change because if pom.currentVersion wasn't setted, the property maven.xdoc.version wasn't used.


          People

          • Assignee:
            Unassigned
            Reporter:
            Erwin Hogeweg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: