Maven 1.x SCM Plugin
  1. Maven 1.x SCM Plugin
  2. MPSCM-61

Exception while executing SCM command.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: 1.5
    • Labels:
      None
    • Environment:
      Sun Solaris 5.8p4
      Java 1.5.0
    • Number of attachments :
      0

      Description

      I'm new to maven, so please excuse if this is my fault, but when something throws me an exception I consider there's a bug. So here you go. I'm trying to checkout my project using maven scm:checkout and this is what I got:

      build:start:

      scm:find-connection:
      [echo] Using connection: scm:cvs:pserver:cvsrep@(obscured):/export1/cvsrep/cibos:Factorial

      scm:checkout:
      [echo] Checking out scm:cvs:pserver:cvsrep@(obscured):/export1/cvsrep/cibos:Factorial

      BUILD FAILED
      File...... /export1/eae/maven/.maven/cache/maven-scm-plugin-1.5/plugin.jelly
      Element... scm:checkout
      Line...... 110
      Column.... 233
      Exception while executing SCM command.
      Total time: 27 seconds
      Finished at: Tue Jul 19 12:22:16 EDT 2005

      Detailed error:

      attaining goal build:start
      attaining goal scm:checkout
      build:start:

      scm:find-connection:
      [echo] Using connection: scm:cvs:pserver:cvsrep@gcatfs1d.ny.ssmb.com:/export1/cvsrep/cibos:Factorial

      scm:checkout:
      [echo] Checking out scm:cvs:pserver:cvsrep@gcatfs1d.ny.ssmb.com:/export1/cvsrep/cibos:Factorial
      popping off org.apache.maven.jelly.MavenJellyContext@c2ee15 for org.apache.maven.jelly.MavenJellyContext@19cd75a in maven-pom-plugin:maven-pom-plugin
      popping off org.apache.maven.jelly.MavenJellyContext@1b03c1a for org.apache.maven.jelly.MavenJellyContext@139e351 in maven-release-plugin:maven-release-plugin
      popping off org.apache.maven.jelly.MavenJellyContext@b7b3f9 for org.apache.maven.jelly.MavenJellyContext@88df60 in maven-changes-plugin:maven-changes-plugin
      popping off org.apache.maven.jelly.MavenJellyContext@157ea4a for org.apache.maven.jelly.MavenJellyContext@d6b059 in maven-artifact-plugin:maven-artifact-plugin
      popping off org.apache.maven.jelly.MavenJellyContext@17ec9f7 for org.apache.maven.jelly.MavenJellyContext@fd918a in maven-xdoc-plugin:maven-xdoc-plugin
      popping off org.apache.maven.jelly.MavenJellyContext@6a3960 for org.apache.maven.jelly.MavenJellyContext@1dccedd in maven-scm-plugin:maven-scm-plugin
      popping off org.apache.maven.jelly.MavenJellyContext@9cb0f4 for org.apache.maven.jelly.MavenJellyContext@125844f in app:app

      BUILD FAILED
      File...... /export1/eae/maven/.maven/cache/maven-scm-plugin-1.5/plugin.jelly
      Element... scm:checkout
      Line...... 110
      Column.... 233
      Exception while executing SCM command.
      com.werken.werkz.UnattainableGoalException: Unable to obtain goal [scm:checkout] – /export1/eae/maven/.maven/cache/maven-scm-plugin-1.5/plugin.jelly:110:233: <scm:checkout> Exception while executing SCM command.
      at com.werken.werkz.Goal.fire(Goal.java:646)
      at com.werken.werkz.Goal.attain(Goal.java:575)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:671)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:488)
      at org.apache.maven.cli.App.main(App.java:1239)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      org.apache.commons.jelly.JellyTagException: /export1/eae/maven/.maven/cache/maven-scm-plugin-1.5/plugin.jelly:110:233: <scm:checkout> Exception while executing SCM command.
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:243)
      at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:145)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      at com.werken.werkz.Goal.fire(Goal.java:639)
      at com.werken.werkz.Goal.attain(Goal.java:575)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:671)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:488)
      at org.apache.maven.cli.App.main(App.java:1239)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      Caused by: org.apache.maven.scm.ScmException: Exception while executing SCM command.
      at org.apache.maven.scm.command.AbstractCommand.execute(AbstractCommand.java:58)
      at org.apache.maven.scm.provider.AbstractScmProvider.execute(AbstractScmProvider.java:131)
      at org.apache.maven.scm.manager.DefaultScmManager.execute(DefaultScmManager.java:299)
      at org.apache.maven.scm.manager.DefaultScmManager.checkOut(DefaultScmManager.java:188)
      at org.apache.maven.plugins.scm.ScmBean.checkout(ScmBean.java:95)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:230)
      ... 16 more
      Caused by: org.apache.maven.scm.ScmException: Error while executing command.
      at org.apache.maven.scm.provider.cvslib.command.checkout.CvsCheckOutCommand.executeCheckOutCommand(CvsCheckOutCommand.java:84)
      at org.apache.maven.scm.command.checkout.AbstractCheckOutCommand.executeCommand(AbstractCheckOutCommand.java:45)
      at org.apache.maven.scm.command.AbstractCommand.execute(AbstractCommand.java:54)
      ... 25 more
      Caused by: org.codehaus.plexus.util.cli.CommandLineException: Error while executing process.
      at org.codehaus.plexus.util.cli.Commandline.execute(Commandline.java:679)
      at org.codehaus.plexus.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:69)
      at org.codehaus.plexus.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:56)
      at org.apache.maven.scm.provider.cvslib.command.checkout.CvsCheckOutCommand.executeCheckOutCommand(CvsCheckOutCommand.java:80)
      ... 27 more
      Caused by: java.io.IOException: cvs: not found
      at java.lang.UNIXProcess.forkAndExec(Native Method)
      at java.lang.UNIXProcess.<init>(UNIXProcess.java:53)
      at java.lang.ProcessImpl.start(ProcessImpl.java:65)
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
      at java.lang.Runtime.exec(Runtime.java:591)
      at org.codehaus.plexus.util.cli.Commandline.execute(Commandline.java:674)
      ... 30 more
      Root cause
      org.apache.maven.scm.ScmException: Exception while executing SCM command.
      at org.apache.maven.scm.command.AbstractCommand.execute(AbstractCommand.java:58)
      at org.apache.maven.scm.provider.AbstractScmProvider.execute(AbstractScmProvider.java:131)
      at org.apache.maven.scm.manager.DefaultScmManager.execute(DefaultScmManager.java:299)
      at org.apache.maven.scm.manager.DefaultScmManager.checkOut(DefaultScmManager.java:188)
      at org.apache.maven.plugins.scm.ScmBean.checkout(ScmBean.java:95)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:230)
      at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:145)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      at com.werken.werkz.Goal.fire(Goal.java:639)
      at com.werken.werkz.Goal.attain(Goal.java:575)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:671)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:488)
      at org.apache.maven.cli.App.main(App.java:1239)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      Caused by: org.apache.maven.scm.ScmException: Error while executing command.
      at org.apache.maven.scm.provider.cvslib.command.checkout.CvsCheckOutCommand.executeCheckOutCommand(CvsCheckOutCommand.java:84)
      at org.apache.maven.scm.command.checkout.AbstractCheckOutCommand.executeCommand(AbstractCheckOutCommand.java:45)
      at org.apache.maven.scm.command.AbstractCommand.execute(AbstractCommand.java:54)
      ... 25 more
      Caused by: org.codehaus.plexus.util.cli.CommandLineException: Error while executing process.
      at org.codehaus.plexus.util.cli.Commandline.execute(Commandline.java:679)
      at org.codehaus.plexus.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:69)
      at org.codehaus.plexus.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:56)
      at org.apache.maven.scm.provider.cvslib.command.checkout.CvsCheckOutCommand.executeCheckOutCommand(CvsCheckOutCommand.java:80)
      ... 27 more
      Caused by: java.io.IOException: cvs: not found
      at java.lang.UNIXProcess.forkAndExec(Native Method)
      at java.lang.UNIXProcess.<init>(UNIXProcess.java:53)
      at java.lang.ProcessImpl.start(ProcessImpl.java:65)
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
      at java.lang.Runtime.exec(Runtime.java:591)
      at org.codehaus.plexus.util.cli.Commandline.execute(Commandline.java:674)
      ... 30 more
      Root cause
      org.apache.maven.scm.ScmException: Exception while executing SCM command.
      at org.apache.maven.scm.command.AbstractCommand.execute(AbstractCommand.java:58)
      at org.apache.maven.scm.provider.AbstractScmProvider.execute(AbstractScmProvider.java:131)
      at org.apache.maven.scm.manager.DefaultScmManager.execute(DefaultScmManager.java:299)
      at org.apache.maven.scm.manager.DefaultScmManager.checkOut(DefaultScmManager.java:188)
      at org.apache.maven.plugins.scm.ScmBean.checkout(ScmBean.java:95)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:230)
      at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:145)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      at com.werken.werkz.Goal.fire(Goal.java:639)
      at com.werken.werkz.Goal.attain(Goal.java:575)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:671)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:488)
      at org.apache.maven.cli.App.main(App.java:1239)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      Caused by: org.apache.maven.scm.ScmException: Error while executing command.
      at org.apache.maven.scm.provider.cvslib.command.checkout.CvsCheckOutCommand.executeCheckOutCommand(CvsCheckOutCommand.java:84)
      at org.apache.maven.scm.command.checkout.AbstractCheckOutCommand.executeCommand(AbstractCheckOutCommand.java:45)
      at org.apache.maven.scm.command.AbstractCommand.execute(AbstractCommand.java:54)
      ... 25 more
      Caused by: org.codehaus.plexus.util.cli.CommandLineException: Error while executing process.
      at org.codehaus.plexus.util.cli.Commandline.execute(Commandline.java:679)
      at org.codehaus.plexus.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:69)
      at org.codehaus.plexus.util.cli.CommandLineUtils.executeCommandLine(CommandLineUtils.java:56)
      at org.apache.maven.scm.provider.cvslib.command.checkout.CvsCheckOutCommand.executeCheckOutCommand(CvsCheckOutCommand.java:80)
      ... 27 more
      Caused by: java.io.IOException: cvs: not found
      at java.lang.UNIXProcess.forkAndExec(Native Method)
      at java.lang.UNIXProcess.<init>(UNIXProcess.java:53)
      at java.lang.ProcessImpl.start(ProcessImpl.java:65)
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)
      at java.lang.Runtime.exec(Runtime.java:591)
      at org.codehaus.plexus.util.cli.Commandline.execute(Commandline.java:674)
      ... 30 more
      Final Memory: 3M/12M
      Total time: 16 seconds
      Finished at: Tue Jul 19 12:23:14 EDT 2005

      Thanks on this.

        Activity

        Trygve Laugstøl added a comment -

        Note:

        [snip]
        Caused by: java.io.IOException: cvs: not found
        [snip]

        which means that you don't have cvs in your PATH.


          People

          • Assignee:
            Unassigned
            Reporter:
            Alex Mayorga Adame
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: