Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: 1.5
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Using v1.5 as shipped with Maven 1-1-beta-1, we recieve the following errors when running scm:update-project:

      --8<----
      [echo] Using connection: scm:cvs:pserver:diong@disti:/cvs:DRPCommon

      scm:update
      [echo] Updating from SCM
      [INFO] Executing: cvs -f -q update -d
      [INFO] Working directory: D:\CruiseControl\build\checkouts\Deployment\..\DRPCommon

      Provider message
      The cvs command failed.

      Command output
      cvs update: move away Java Source/au/com/suttons/drp/copier/BackendCopier.java; it is in the way
      cvs update: move away Java Source/au/com/suttons/drp/copier/Copier.java; it is in the way
      cvs update: move away Java Source/au/com/suttons/drp/copier/WebAppCopier.java; it is in the way
      cvs update: move away xdocs/images/STAR Project Logo 1.gif; it is in the way
      cvs update: move away xdocs/images/id_suttons_logo.gif; it is in the way

      --->8----------

      Simply replacing 1.5 with 1.4.1 gives us a working scm with no errors.

        Activity

        dion gillard added a comment -

        Is there going to be anything done about this issue?

        dion gillard added a comment -

        Also,

        after deleting the files being complained about and checking them out again (using cvs checkout), the same error is displayed.

        dion gillard added a comment -

        Problem was caused by the adding of the "-d" option to the update command.
        This broke CVSNT 2.0.12a. Fixed by upgrading to a later version of CVSNT.

        Arnaud Heritier added a comment -

        Dion found the problem : It's a cvsnt issue


          People

          • Assignee:
            Arnaud Heritier
            Reporter:
            dion gillard
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: