Maven 1.x SCM Plugin
  1. Maven 1.x SCM Plugin
  2. MPSCM-33

maven.scm.bootstrap.pom.dir is not used

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5
    • Labels:
      None
    • Environment:
      JDK 1.4, Windows XP
    • Number of attachments :
      0

      Description

      I have a flat directory structure in CVS, with my maven files in a directory called "maven". Like this:

      module

      • project1/project.xml
      • project2/project.xml
      • ...
      • maven/project.xml (master project which all others inherit)

      The checkout is fine but then it seems the maven scm:bootstrap-project goal can't find my maven/project.xml:

      [maven@orgsld08 tmp]$ maven -Dmaven.scm.method=cvs -Dmaven.scm.cvs.module=sources-malibu -Dmaven.scm.bootstrap.pom.dir=maven -Dmaven.scm.bootstrap.goals=multiproject:deploy,multiproject:site,site:deploy scm:bootstrap-project

      <snip>
      [cvs] U sources-malibu/maven/logo/cs_logo.jpg
      [cvs] U sources-malibu/maven/logo/logo_new_rvb.jpg

      BUILD FAILED
      File...... /export/home/cgey/maven/.maven/cache/maven-scm-plugin-1.4/plugin.jelly
      Element... maven:maven
      Line...... 158
      Column.... 9
      Error parsing project.xml '/export/home/cgey/maven/tmp/target/checkouts/sources-malibu/project.xml'
      Total time: 24 minutes 52 seconds
      Finished at: Thu Oct 28 16:22:36 CEST 2004

      I've used -Dmaven.scm.bootstrap.pom.dir=maven so I think it should look in $module/maven which for me is sources-malibu/maven/project.xml but it doesn't find it.

      Brett confirmed that it looks like a bug and asked me to file it in JIRA. I had the same problem about 4 months ago and finally gave up on it, so it looks to me like this has been broken for quite a while.

      Thanks,
      Michael

        Activity

        Michael added a comment -

        I can't update the issue, so I will add it here. This is for version 1.0.

        Brett Porter added a comment -

        this may be related to MPSCM-22.

        There are some other issues:

        • bootstrap mixes in some logic for doing releases (the check.tagged bit)
        • it appears that according to Michael, -Dmaven.scm.check.tagged=false does not resolve this issue, so perhaps that option is not working.

          People

          • Assignee:
            Brett Porter
            Reporter:
            Michael
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: