Maven 1.x Plugin Plugin
  1. Maven 1.x Plugin Plugin
  2. MPPLUGIN-11

the generated jar should automatically include plugin.jelly and friends

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 1.7
    • Labels:
      None
    • Number of attachments :
      0

      Description

      When you create a plugin jar with the plugin plugin, it does not include plugin.jelly and friends by default.
      Plugins in maven-plugins get that by extending the main project.xml, but for custom plugins this is annyoing. You have to add the follogin to the project.xml of the plugin:

      <resources>
      <resource>
      <directory>src/plugin-resources</directory>
      <targetPath>plugin-resources</targetPath>
      </resource>
      <resource>
      <directory>.</directory>
      <includes>
      <include>plugin.jelly</include>
      <include>plugin.properties</include>
      <include>project.properties</include>
      <include>project.xml</include>
      </includes>
      </resource>
      </resources>

      It seems to me that the plugin plugin should include those resources in the generate jar by default (at least the four files in ".", the other resources are more dependent on the structure of the custom plugin, so we can leave that for the author to configure in the pom if needed).

        Activity

        dion gillard made changes -
        Field Original Value New Value
        Assignee dion gillard [ diongillard ]
        Brett Porter made changes -
        Assignee Brett Porter [ brettporter ]
        Brett Porter made changes -
        Assignee Brett Porter [ brettporter ]
        Lukas Theussl added a comment -

        Must have been fixed be someone somewhere ...

        Lukas Theussl made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 1.7 [ 11766 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Daniel Bonniot
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: