Maven 1.x PDF Plugin
  1. Maven 1.x PDF Plugin
  2. MPPDF-7

PDF generation does not utilise proxy settings for external resources

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.4
    • Labels:
      None
    • Number of attachments :
      0

      Description

      PDF generation does not utilise proxy settings for external resources

        Activity

        Arnaud Heritier added a comment -

        When you say "external ressources", you think images for example ?
        I'll watch if it is possible to use a proxy with fop.

        Brett Porter added a comment -

        yes, this is what I meant

        Arnaud Heritier added a comment -

        Can you reproduce it with "maven.pdf.debug=true" and send me te log please?
        I searched on the net and didn't find this problem with FOP.

        Arnaud Heritier added a comment -

        To generate the PDF for maven you can get round this problem replacing this properties :

        maven.pdf.projectLogo=http://maven.apache.org/images/maven.gif
        maven.pdf.companyLogo=http://maven.apache.org/images/asf_logo_wide_clear.gif

        by :

        maven.pdf.projectLogo=/images/maven.gif
        maven.pdf.companyLogo=/images/asf_logo_wide_clear.gif

        I don't know why everybody uses the absolute url.
        It will be better because fop won't download images from the net but will use the local ones.

        Arnaud Heritier added a comment -

        I found this on the net :
        <java classname="org.apache.fop.apps.Fop" fork="true">

        <jvmarg value="-DproxySet=$

        {proxy.used}

        "/>
        <jvmarg value="-DproxyHost=$

        {proxy.host}

        "/>
        <jvmarg value="-DproxyPort=$

        {proxy.port}

        "/>

        <classpath refid="fop.classpath"/>
        <arg line="-xml $

        {input.file}

        "/>
        <arg line="-xsl $

        {docbook.dir}

        /fo/docbook.xsl"/>
        <arg value="$

        {output.pdf}

        "/>
        </java>
        If I use it in the plugin, is there someone who can test it ?

        Arnaud Heritier added a comment -

        Must be fixed but I can't test it. If there's always a problem, we'll reopen it.


          People

          • Assignee:
            Arnaud Heritier
            Reporter:
            Brett Porter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: