Maven 1.x PDF Plugin
  1. Maven 1.x PDF Plugin
  2. MPPDF-50

maven.pdf.cover.projectCompany is always "Apache Software Foundation"

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.5
    • Labels:
      None
    • Environment:
      Maven 1.1 beta 2, PDF plugin 2.4 (included in 1.1b2 release), Win 2K
    • Number of attachments :
      0

      Description

      maven.pdf.cover.projectCompany doesn't seem to default to "$

      {pom.organization.name}

      ". Explicitly setting maven.pdf.cover.projectCompany in project.properties also has no effect.
      My assumption is maven.pdf.cover.projectCompany contains the value printed at the bottom of the cover page. "Apache Software Foundation" is always printed there.

        Activity

        Lukas Theussl added a comment -

        A simple bug in the jelly script, its fixed. Thanks!

        Arnaud Heritier added a comment -

        You can test it :
        maven plugin:download -Dmaven.repo.remote=http:www.ibiblio.org/maven,http://cvs.apache.org/repository/ -DgroupId=maven -DartifactId=maven-pdf-plugin -Dversion=2.5-SNAPSHOT

        Jeff Jensen added a comment -

        Great turnaround, thanks a ton!

        This new version does not find the nav.xml file though...appears relative to a root path. These values are now blank, and they were populated before. I think this is the hint to the cause.
        maven.docs.src = []
        maven.docs.dest = []
        maven.gen.docs = []

        fo:fo:
        [echo] Generating c:/devroot/healthmatch/builds/healthmatchmultiproject/pdf/project.fo from /navigation-pdf-perforce.xml ...

        BUILD FAILED
        File...... C:\Documents and Settings\pwjjj69\.maven\cache\maven-pdf-plugin-2.5-SNAPSHOT\plugin.jelly
        Element... fail
        Line...... 122
        Column.... -1
        PDF generation cannot complete as /navigation-pdf-perforce.xml is missing
        Total time : 8 seconds
        Finished at : Tuesday, September 20, 2005 1:51:09 PM CDT

        Arnaud Heritier added a comment -

        Can you give us more informations about your project, your environment, the log....
        We don't succeed to reproduce your problem.
        It seems you use a multiproject.
        We have actually some problems with multiproject so it can be a problem in maven's core and not in the pdf plugin.
        Can you try to create the pdf directly in your subproject to test if it works.

        Jeff Jensen added a comment -

        This is how I run it:
        set MAVEN_OPTS=-Xmx1024m
        call maven -p projectperforcefaq.xml -Dmaven.pdf.navigationFile=navigation-pdf-perforce.xml pdf

        I run it this way because I already have a PDF defined for the project, and need a PDF of only this FAQ (actually that is an enhancement request - allow config of multiple PDFs per project!).

        I will attach a log run and my config files.

        WOW - I just ran it again to get a complete log for you, and it worked this time! I have no idea why - I ran it a number of times prior, and it failed each time.

        Consider it closed. Fantastic! Thanks a again!

        Arnaud Heritier added a comment -

        maven is magic

        Jeff Jensen added a comment -

        Perhaps, but sorry, I think instead you missed your opportunity to say "See how good I am! I fixed it without you noticing" LOL!

        Arnaud Heritier added a comment -

        It could be possible.
        You're using a SNAPSHOT, thus I could update it on the server and your maven could download it

        But it wasn't the case


          People

          • Assignee:
            Arnaud Heritier
            Reporter:
            Jeff Jensen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: