Maven 1.x PDF Plugin
  1. Maven 1.x PDF Plugin
  2. MPPDF-47

An error occurs if the project logo or the company logo aren't defined.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.5
    • Labels:
      None
    • Environment:
      W2K, Maven 1.0.2
    • Testcase included:
      yes
    • Number of attachments :
      2

      Description

      I get the error below when I call "maven pdf":

      — snip —
      testApp\param_problem>maven pdf
      __ __

      \/ __ Apache_ ___
        \/ / ` \ V / -) ' \ ~ intelligent projects ~
      _   _,_ _/___ _ _ v. 1.0.2

      build:start:

      xdoc:init:

      pdf:init:
      [mkdir] Created dir: testApp\
      param_problem\target\pdf

      pdf:prepare:
      [copy] Copying 9 files to testApp\param_problem\target\pdf
      [copy] Copying 3 files to testApp\param_problem\target\pdf
      [copy] Copying 94 files to testApp\param_problem\target\pdf
      [copy] Copying 7 files to testApp\param_problem\target\pdf

      fo:fo:
      [echo] Generating testApp\param_problem/target/pdf/project.fo from testApp\p
      aram_problem/xdocs/navigation.xml ...
      [java] Ung≥ltige Option: imageDpi
      [java] Ung≥ltige Option: 72
      [java] file:///C:/Dokumente%20und%20Einstellungen/stefan/.maven/cache/maven-
      pdf-plugin-2.4/plugin-resources/project2fo.xslt; Zeile #173; Spalte #97; Angefor
      dertes Dokument kann nicht geladen werden: c:\daten\suncom\proj\imcNetworks\dais
      y\corporate_audit\param_problem\target\pdf\jdepend-report.xml (Das System kann d
      ie angegebene Datei nicht finden)
      [java] file:///C:/Dokumente%20und%20Einstellungen/stefan/.maven/cache/maven-
      pdf-plugin-2.4/plugin-resources/project2fo.xslt; Zeile #173; Spalte #97; Angefor
      dertes Dokument kann nicht geladen werden: c:\daten\suncom\proj\imcNetworks\dais
      y\corporate_audit\param_problem\target\pdf\locc-report.xml (Das System kann die
      angegebene Datei nicht finden)
      [java] file:///C:/Dokumente%20und%20Einstellungen/stefan/.maven/cache/maven-
      pdf-plugin-2.4/plugin-resources/project2fo.xslt; Zeile #173; Spalte #97; Angefor
      dertes Dokument kann nicht geladen werden: c:\daten\suncom\proj\imcNetworks\dais
      y\corporate_audit\param_problem\target\pdf\checkstyle-report.xml (Das System kan
      n die angegebene Datei nicht finden)
      [java] file:///C:/Dokumente%20und%20Einstellungen/stefan/.maven/cache/maven-
      pdf-plugin-2.4/plugin-resources/project2fo.xslt; Zeile #173; Spalte #97; Angefor
      dertes Dokument kann nicht geladen werden: c:\daten\suncom\proj\imcNetworks\dais
      y\corporate_audit\param_problem\target\pdf\simian-report.xml (Das System kann di
      e angegebene Datei nicht finden)
      [java] file:///C:/Dokumente%20und%20Einstellungen/stefan/.maven/cache/maven-
      pdf-plugin-2.4/plugin-resources/project2fo.xslt; Zeile #173; Spalte #97; Angefor
      dertes Dokument kann nicht geladen werden: c:\daten\suncom\proj\imcNetworks\dais
      y\corporate_audit\param_problem\target\pdf.xml (Das System kann die angegebene D
      atei nicht finden)
      [java]

      pdf:pdf:
      [echo] Generating testApp\param_problem/target/pdf/TestApp.pdf ...
      [echo] Config file: testApp\p
      aram_problem/target/pdf/userconfig.xml
      [java] [INFO] Using org.apache.xerces.parsers.SAXParser as SAX2 Parser
      [java] [INFO] Using org.apache.xerces.parsers.SAXParser as SAX2 Parser
      [java] [INFO] FOP 0.20.5
      [java] [INFO] Using org.apache.xerces.parsers.SAXParser as SAX2 Parser
      [java] [INFO] building formatting object tree
      [java] [INFO] setting up fonts
      [java] [INFO] [1]
      [java] [ERROR] Error while creating area : Error while recovering Image Info
      rmations (file:/C:/daten/suncom/proj/imcNetworks/daisy/corporate_audit/param_pro
      blem/target/pdf/-PARAM) : testApp\param_problem\target\pdf-PARAM (Das System ka
      nn die angegebene Datei nicht finden)
      [java] [INFO] [2] (blank)
      [java] [INFO] [1]
      [java] [INFO] [2] (blank)
      [java] [INFO] [1]
      [java] [INFO] Using org.apache.xerces.parsers.SAXParser as SAX2 Parser
      [java] [INFO] [2]
      [java] [INFO] [3]
      [java] [INFO] [4]
      [java] [INFO] [5]
      [java] [INFO] [6]
      [java] [INFO] [7]
      [java] [INFO] [8]
      [java] [INFO] [9]
      [java] [INFO] Parsing of document complete, stopping renderer
      [copy] Copying 1 file to testApp\param_problem\target\docs
      BUILD SUCCESSFUL
      Total time: 5 seconds
      Finished at: Sun Sep 18 14:16:08 GMT+01:00 2005
      — snip —

        Activity

        Lukas Theussl added a comment -

        Strange, I cannot reproduce that (tried with maven 1.0.2 and 1.1, java 1.4 on Linux fc3, pdf-plugin 2.4). Maybe something is wrong with your setup? How did you install the plugin, can you try to re-install (maven plugin:download -Dmaven.repo.remote=http://www.ibiblio.org/maven -DgroupId=maven -DartifactId=maven-pdf-plugin -Dversion=2.4) to see if that helps.

        Arnaud Heritier added a comment -

        I reproduced it, here is the full log file

        Arnaud Heritier added a comment -

        this is because the project's logo is not defined

        Arnaud Heritier added a comment -

        It's fixed.
        You can test it :
        maven plugin:download -Dmaven.repo.remote=http:www.ibiblio.org/maven,http://cvs.apache.org/repository/ -DgroupId=maven -DartifactId=maven-pdf-plugin -Dversion=2.5-SNAPSHOT


          People

          • Assignee:
            Arnaud Heritier
            Reporter:
            Stefan Undorf
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: