Maven 1.x Multi-Project Plugin
  1. Maven 1.x Multi-Project Plugin
  2. MPMULTIPROJECT-4

Provide the ability to ignore a particular project via the project.properties for that project

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Multiproject currently allows exclusion of projects via maven.multiproject.excludes, but this approach requires constant upkeep of the multiproject parent. I'd like to be able to specify a property that would tell multiproject to ignore a given project. This brings the responsibility of whether or not multiproject should process a project down to the project level.

      Perhaps maven.multiproject.type could accept a "none" or "ignore" value?

        Activity

        dion gillard added a comment -

        A bit more detail. I don't get it.

        Sean Timm added a comment -

        The problem is that certain goals don't make sense for any given project. For example, I've got a project that exists solely for the purpose of deploying to JBoss using pre-built components generated by other projects, so in this case, the jar:jar goal makes no sense (and ends up generating a junk .jar file that is of no use to anyone). This issue can be more more generalized to say that I should be able to specify goals that do or do not make sense for a given project, and multiproject will make sure to ignore that particular project if the particular goal it is attempting to run is excluded (for that project). Does that help?

        Michael Osipov added a comment -

        Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.


          People

          • Assignee:
            Unassigned
            Reporter:
            Sean Timm
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: