Maven PMD Plugin
  1. Maven PMD Plugin
  2. MPMD-99

Report doesn't reflect the real PMD version used

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.5
    • Component/s: PMD
    • Labels:
      None
    • Number of attachments :
      1

      Description

      If the PMD dependency is overloaded to a new version of PMD (by having a dependency section attached to the plugin definition in the pom.xml), PMD won't show the real PMD version used.

      This is because, the version shown following the "The following document contains the results of" on the html report is taken from PMD.VERSION which is inlined by the compiler at compilation and so is always 4.2.2.

      The solution is to use the one in the pmd.xml header (<pmd version="4.2.5" timestamp="2009-06-04T18:29:18.945">) which is always right.

        Activity

        Henri Tremblay made changes -
        Field Original Value New Value
        Attachment PmdReportListener.java [ 42644 ]
        Herve Boutemy made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Herve Boutemy [ hboutemy ]
        Fix Version/s 2.5 [ 14419 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Herve Boutemy
            Reporter:
            Henri Tremblay
          • Votes:
            2 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: