Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Activity

      Maria Odea Ching added a comment -

      The plugin already has the ff. in its documentation:

      • Most classes already have javadoc tags
      • HowTo apt

      To do:

      • Put additional javadoc tags
      • Set standard reports in the pom
      • Review existing HowTo apt for the usage apt
      • Create overview, faq, and examples apt
      Maria Odea Ching added a comment -

      Waiting for review..

      Mike Perham added a comment -

      I'm not sure if there is a review standard but I just read through the docs, made a few small changes (grammar and added FAQs) and think it looks to be in good shape.

      Brett Porter added a comment -
      • rename overview to index
      • goal links don't work
      • I don't think the example of pmd in the build section is that relevant
      • examples links don't work
      Brett Porter added a comment -

      also:

      • put generatingPmdAndCpd.html into usage.html
      • the reason the links aren't working is I use site:run. Make sure you add a leading / in front of the examples link in the site descriptor
      • look out for more goal names and things that could use <<<formatting>>>
      Mike Perham added a comment -

      I'll update the docs per Brett's comments.

      Mike Perham added a comment -

      Fixed several of the bulletpoints. I was able to reproduce your problem with the example links but putting a leading slash in front of them didn't have any effect. They work fine when just browsing the HTML from the filesystem.

      Maria, feel free to close this issue if the docs look good to you.

      Dennis Lundberg added a comment -

      I've read through the docs and it looks good. I just fixed a couple of typos and added formating and license where it was needed. Also fixed the last remaining docck error.


        People

        • Assignee:
          Mike Perham
          Reporter:
          Maria Odea Ching
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Due:
            Created:
            Updated:
            Resolved:

            Time Tracking

            Estimated:
            Original Estimate - 12 hours Original Estimate - 12 hours
            12h
            Remaining:
            Remaining Estimate - 0 minutes
            0m
            Logged:
            Time Spent - 15 hours
            15h