Maven Plugin Tools
  1. Maven Plugin Tools
  2. MPLUGIN-188

.NoSuchMethodError: org.apache.maven.settings.RuntimeInfo.<init>(Lorg/apache/maven/settings/Settings

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 2.3
    • Fix Version/s: None
    • Component/s: Plugin Plugin
    • Labels:
      None
    • Environment:
    • Number of attachments :
      0

      Description

      Hi

      Got this NoSuchMethodError when building the maven-jax2b-plugin

      [INFO] Reactor Summary:
      [INFO]
      [INFO] Maven JAXB 2.x Plugin Project ..................... SUCCESS [2.782s]
      [INFO] Maven JAXB 2.x Plugin Core ........................ SUCCESS [11.031s]
      [INFO] Maven JAXB 2.0.x Plugin ........................... FAILURE [2.094s]
      [INFO] Maven JAXB 2.1.x Plugin ........................... SKIPPED
      [INFO] Maven JAXB 2.2.x Plugin ........................... SKIPPED
      [INFO] Maven JAXB 2.x Plugin ............................. SKIPPED
      [INFO] Maven JAXB 2.x Plugin Testing ..................... SKIPPED
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 16.735s
      [INFO] Finished at: Thu Oct 06 04:43:12 CEST 2011
      [INFO] Final Memory: 8M/23M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-plugin-plugin:2.3:descriptor (default-descriptor) on proje
      ct maven-jaxb20-plugin: Execution default-descriptor of goal org.apache.maven.plugins:maven-plugin-plugin:2.3:descriptor
      failed: An API incompatibility was encountered while executing org.apache.maven.plugins:maven-plugin-plugin:2.3:descrip
      tor: java.lang.NoSuchMethodError: org.apache.maven.settings.RuntimeInfo.<init>(Lorg/apache/maven/settings/Settings;)V
      [ERROR] -----------------------------------------------------
      [ERROR] realm = plugin>org.apache.maven.plugins:maven-plugin-plugin:2.3
      [ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
      [ERROR] urls[0] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/plugins/maven-plugin-
      plugin/2.3/maven-plugin-plugin-2.3.jar
      [ERROR] urls[1] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/jfrog/maven/annomojo/maven-plugin-
      tools-anno/1.3.1/maven-plugin-tools-anno-1.3.1.jar
      [ERROR] urls[2] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/jfrog/maven/annomojo/maven-plugin-
      anno/1.3.1/maven-plugin-anno-1.3.1.jar
      [ERROR] urls[3] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/codehaus/plexus/plexus-utils/1.1/p
      lexus-utils-1.1.jar
      [ERROR] urls[4] = file:/C:/Progra~1/Java/jdk1.6.0_26/jre/../lib/tools.jar
      [ERROR] urls[5] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/junit/junit/3.8.1/junit-3.8.1.jar
      [ERROR] urls[6] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-ap
      i/2.1/maven-plugin-tools-api-2.1.jar
      [ERROR] urls[7] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-ja
      va/2.1/maven-plugin-tools-java-2.1.jar
      [ERROR] urls[8] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/qdox/qdox/1.6.1/qdox-1.6.1.jar
      [ERROR] urls[9] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-be
      anshell/2.1/maven-plugin-tools-beanshell-2.1.jar
      [ERROR] urls[10] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/bsh/bsh/1.3.0/bsh-1.3.0.jar
      [ERROR] urls[11] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/reporting/maven-repo
      rting-impl/2.0/maven-reporting-impl-2.0.jar
      [ERROR] urls[12] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/commons-validator/commons-validator/1
      .1.4/commons-validator-1.1.4.jar
      [ERROR] urls[13] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/oro/oro/2.0.7/oro-2.0.7.jar
      [ERROR] urls[14] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/reporting/maven-repo
      rting-api/2.0/maven-reporting-api-2.0.jar
      [ERROR] urls[15] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/doxia/doxia-sink-api/1.0-alpha-4/doxi
      a-sink-api-1.0-alpha-4.jar
      [ERROR] urls[16] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/doxia/doxia-core/1.0-alpha-4/doxia-co
      re-1.0-alpha-4.jar
      [ERROR] Number of foreign imports: 1
      [ERROR] import: Entry[import from realm ClassRealm[maven.api, parent: null]]
      [ERROR]
      [ERROR] -----------------------------------------------------
      [ERROR] -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-plugin-plu
      gin:2.3:descriptor (default-descriptor) on project maven-jaxb20-plugin: Execution default-descriptor of goal org.apache.
      maven.plugins:maven-plugin-plugin:2.3:descriptor failed: An API incompatibility was encountered while executing org.apac
      he.maven.plugins:maven-plugin-plugin:2.3:descriptor: java.lang.NoSuchMethodError: org.apache.maven.settings.RuntimeInfo.
      <init>(Lorg/apache/maven/settings/Settings;)V
      -----------------------------------------------------
      realm = plugin>org.apache.maven.plugins:maven-plugin-plugin:2.3
      strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
      urls[0] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/plugins/maven-plugin-plugin/2
      .3/maven-plugin-plugin-2.3.jar
      urls[1] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/jfrog/maven/annomojo/maven-plugin-tools-an
      no/1.3.1/maven-plugin-tools-anno-1.3.1.jar
      urls[2] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/jfrog/maven/annomojo/maven-plugin-anno/1.3
      .1/maven-plugin-anno-1.3.1.jar
      urls[3] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/codehaus/plexus/plexus-utils/1.1/plexus-ut
      ils-1.1.jar
      urls[4] = file:/C:/Progra~1/Java/jdk1.6.0_26/jre/../lib/tools.jar
      urls[5] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/junit/junit/3.8.1/junit-3.8.1.jar
      urls[6] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-api/2.1/ma
      ven-plugin-tools-api-2.1.jar
      urls[7] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-java/2.1/m
      aven-plugin-tools-java-2.1.jar
      urls[8] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/qdox/qdox/1.6.1/qdox-1.6.1.jar
      urls[9] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-beanshell/
      2.1/maven-plugin-tools-beanshell-2.1.jar
      urls[10] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/bsh/bsh/1.3.0/bsh-1.3.0.jar
      urls[11] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/reporting/maven-reporting-im
      pl/2.0/maven-reporting-impl-2.0.jar
      urls[12] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/commons-validator/commons-validator/1.1.4/com
      mons-validator-1.1.4.jar
      urls[13] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/oro/oro/2.0.7/oro-2.0.7.jar
      urls[14] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/reporting/maven-reporting-ap
      i/2.0/maven-reporting-api-2.0.jar
      urls[15] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/doxia/doxia-sink-api/1.0-alpha-4/doxia-sink-a
      pi-1.0-alpha-4.jar
      urls[16] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/doxia/doxia-core/1.0-alpha-4/doxia-core-1.0-a
      lpha-4.jar
      Number of foreign imports: 1
      import: Entry[import from realm ClassRealm[maven.api, parent: null]]

      -----------------------------------------------------

      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:225)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
      at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
      at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
      at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      Caused by: org.apache.maven.plugin.PluginExecutionException: Execution default-descriptor of goal org.apache.maven.plugi
      ns:maven-plugin-plugin:2.3:descriptor failed: An API incompatibility was encountered while executing org.apache.maven.pl
      ugins:maven-plugin-plugin:2.3:descriptor: java.lang.NoSuchMethodError: org.apache.maven.settings.RuntimeInfo.<init>(Lorg
      /apache/maven/settings/Settings;)V
      -----------------------------------------------------
      realm = plugin>org.apache.maven.plugins:maven-plugin-plugin:2.3
      strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
      urls[0] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/plugins/maven-plugin-plugin/2
      .3/maven-plugin-plugin-2.3.jar
      urls[1] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/jfrog/maven/annomojo/maven-plugin-tools-an
      no/1.3.1/maven-plugin-tools-anno-1.3.1.jar
      urls[2] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/jfrog/maven/annomojo/maven-plugin-anno/1.3
      .1/maven-plugin-anno-1.3.1.jar
      urls[3] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/codehaus/plexus/plexus-utils/1.1/plexus-ut
      ils-1.1.jar
      urls[4] = file:/C:/Progra~1/Java/jdk1.6.0_26/jre/../lib/tools.jar
      urls[5] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/junit/junit/3.8.1/junit-3.8.1.jar
      urls[6] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-api/2.1/ma
      ven-plugin-tools-api-2.1.jar
      urls[7] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-java/2.1/m
      aven-plugin-tools-java-2.1.jar
      urls[8] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/qdox/qdox/1.6.1/qdox-1.6.1.jar
      urls[9] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-beanshell/
      2.1/maven-plugin-tools-beanshell-2.1.jar
      urls[10] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/bsh/bsh/1.3.0/bsh-1.3.0.jar
      urls[11] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/reporting/maven-reporting-im
      pl/2.0/maven-reporting-impl-2.0.jar
      urls[12] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/commons-validator/commons-validator/1.1.4/com
      mons-validator-1.1.4.jar
      urls[13] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/oro/oro/2.0.7/oro-2.0.7.jar
      urls[14] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/reporting/maven-reporting-ap
      i/2.0/maven-reporting-api-2.0.jar
      urls[15] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/doxia/doxia-sink-api/1.0-alpha-4/doxia-sink-a
      pi-1.0-alpha-4.jar
      urls[16] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/doxia/doxia-core/1.0-alpha-4/doxia-core-1.0-a
      lpha-4.jar
      Number of foreign imports: 1
      import: Entry[import from realm ClassRealm[maven.api, parent: null]]

      -----------------------------------------------------

      at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:139)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
      ... 19 more
      Caused by: org.apache.maven.plugin.PluginContainerException: An API incompatibility was encountered while executing org.
      apache.maven.plugins:maven-plugin-plugin:2.3:descriptor: java.lang.NoSuchMethodError: org.apache.maven.settings.RuntimeI
      nfo.<init>(Lorg/apache/maven/settings/Settings;)V
      -----------------------------------------------------
      realm = plugin>org.apache.maven.plugins:maven-plugin-plugin:2.3
      strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
      urls[0] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/plugins/maven-plugin-plugin/2
      .3/maven-plugin-plugin-2.3.jar
      urls[1] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/jfrog/maven/annomojo/maven-plugin-tools-an
      no/1.3.1/maven-plugin-tools-anno-1.3.1.jar
      urls[2] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/jfrog/maven/annomojo/maven-plugin-anno/1.3
      .1/maven-plugin-anno-1.3.1.jar
      urls[3] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/codehaus/plexus/plexus-utils/1.1/plexus-ut
      ils-1.1.jar
      urls[4] = file:/C:/Progra~1/Java/jdk1.6.0_26/jre/../lib/tools.jar
      urls[5] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/junit/junit/3.8.1/junit-3.8.1.jar
      urls[6] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-api/2.1/ma
      ven-plugin-tools-api-2.1.jar
      urls[7] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-java/2.1/m
      aven-plugin-tools-java-2.1.jar
      urls[8] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/qdox/qdox/1.6.1/qdox-1.6.1.jar
      urls[9] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/maven-plugin-tools-beanshell/
      2.1/maven-plugin-tools-beanshell-2.1.jar
      urls[10] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/bsh/bsh/1.3.0/bsh-1.3.0.jar
      urls[11] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/reporting/maven-reporting-im
      pl/2.0/maven-reporting-impl-2.0.jar
      urls[12] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/commons-validator/commons-validator/1.1.4/com
      mons-validator-1.1.4.jar
      urls[13] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/oro/oro/2.0.7/oro-2.0.7.jar
      urls[14] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/org/apache/maven/reporting/maven-reporting-ap
      i/2.0/maven-reporting-api-2.0.jar
      urls[15] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/doxia/doxia-sink-api/1.0-alpha-4/doxia-sink-a
      pi-1.0-alpha-4.jar
      urls[16] = file:/C:/Documents%20and%20Settings/FrancisANDRE/.m2/repository/doxia/doxia-core/1.0-alpha-4/doxia-core-1.0-a
      lpha-4.jar
      Number of foreign imports: 1
      import: Entry[import from realm ClassRealm[maven.api, parent: null]]

      -----------------------------------------------------

      at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:137)
      ... 20 more
      Caused by: java.lang.NoSuchMethodError: org.apache.maven.settings.RuntimeInfo.<init>(Lorg/apache/maven/settings/Settings
      ;)V
      at org.jfrog.maven.annomojo.extractor.Maven20Helper.buildSettings(Maven20Helper.java:143)
      at org.jfrog.maven.annomojo.extractor.Maven20Helper.buildSettings(Maven20Helper.java:112)
      at org.jfrog.maven.annomojo.extractor.Maven20Helper.getLocalRepositoryPath(Maven20Helper.java:219)
      at org.jfrog.maven.annomojo.extractor.Maven20Helper.getLocalRepository(Maven20Helper.java:229)
      at org.jfrog.maven.annomojo.extractor.AnnoMojoDescriptorExtractor.resolveDependencies(AnnoMojoDescriptorExtracto
      r.java:149)
      at org.jfrog.maven.annomojo.extractor.AnnoMojoDescriptorExtractor.execute(AnnoMojoDescriptorExtractor.java:105)
      at org.apache.maven.tools.plugin.scanner.DefaultMojoScanner.populatePluginDescriptor(DefaultMojoScanner.java:84)

      at org.apache.maven.plugin.plugin.AbstractGeneratorMojo.execute(AbstractGeneratorMojo.java:135)
      at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
      ... 20 more
      [ERROR]
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException
      [ERROR]
      [ERROR] After correcting the problems, you can resume the build with the command
      [ERROR] mvn <goals> -rf :maven-jaxb20-plugin
      D:\OSI\maven-jaxb2-plugin>

        Activity

        Robert Scholte added a comment -

        Caused by: java.lang.NoSuchMethodError: org.apache.maven.settings.RuntimeInfo.<init>(Lorg/apache/maven/settings/Settings
        ;)V
        at org.jfrog.maven.annomojo.extractor.Maven20Helper.buildSettings(Maven20Helper.java:143)

        What makes you think it's a maven-plugin-plugin issue and not a Anno Mojo issue?

        zosrothko added a comment -

        You are right... it is a Anno Mojo issue.... I didn't check up to this point.

        Robert Scholte added a comment -

        Not a maven-plugin-plugin bug


          People

          • Assignee:
            Robert Scholte
            Reporter:
            zosrothko
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: