Maven Plugin Tools
  1. Maven Plugin Tools
  2. MPLUGIN-186

Plugins with no mojos lead to exception and failure in PluginReport

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.8
    • Fix Version/s: 2.9
    • Component/s: Plugin Plugin
    • Labels:
      None
    • Number of attachments :
      0

      Description

      If a plugin has no mojos, because it exists purely to add a lifecycle, a backtrace and failure reports:

      I'm just supplying the tail of it.

      Caused by: org.apache.maven.reporting.MavenReportException: Error extracting plugin descriptor: 'No mojo definitions were found for plugin: org.eclipse.tycho:tycho-maven-plugin.'
      at org.apache.maven.plugin.plugin.PluginReport.executeReport(PluginReport.java:231)
      at org.apache.maven.reporting.AbstractMavenReport.generate(AbstractMavenReport.java:135)
      at org.apache.maven.plugins.site.ReportDocumentRenderer.renderDocument(ReportDocumentRenderer.java:228)
      ... 25 more
      Caused by: org.apache.maven.plugin.descriptor.InvalidPluginDescriptorException: No mojo definitions were found for plugin: org.eclipse.tycho:tycho-maven-plugin.
      at org.apache.maven.tools.plugin.scanner.DefaultMojoScanner.populatePluginDescriptor(DefaultMojoScanner.java:121)
      at org.apache.maven.plugin.plugin.PluginReport.executeReport(PluginReport.java:219)
      ... 27 more

        Activity

        Benson Margulies added a comment -

        This jira is in the wrong place. It needs to stick to 'PluginReport', not 'PluginsReport'. I'll fix it.

        Benson Margulies added a comment -

        1164525


          People

          • Assignee:
            Benson Margulies
            Reporter:
            Benson Margulies
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: