Maven 1.x JXR Plugin
  1. Maven 1.x JXR Plugin
  2. MPJXR-26

package-info.java files cause a NullPointerException

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.2, 1.4.3
    • Fix Version/s: 1.4.3
    • Labels:
      None
    • Number of attachments :
      0

      Description

      If any package-info.java file is present in the source folder a NullPointerException is thrown.

      The issue is in CodeTransform.getHeader()

      FileManager.getInstance().getFile(this.getCurrentFilename()).getClassType().getName())

      getClassType() returns null

        Activity

        Carlos Sanchez added a comment -

        package-info.java files are now ignored


          People

          • Assignee:
            Carlos Sanchez
            Reporter:
            Carlos Sanchez
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: