Maven 1.x Javadoc Plugin
  1. Maven 1.x Javadoc Plugin
  2. MPJAVADOC-8

Offline Javadoc generation not generating online links

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      JDK1.4.1, Win2K
    • Number of attachments :
      1

      Description

      Trying to generate online javadoc links from using local package lists does not work. Using the format specified - maven.javadoc.offlineLinks=http://href/#local/package/dir/ - causes javadoc to try and resolve http://href/package-list. Not exactly sure why, but check the attached CVS diff for a patch that /seems/ to work.

      Basically, to my Java programming eyes, it's a bug caused by not putting your if blocks in braces...

        Activity

        Nick Giles added a comment -

        Diff to plugin.jelly script

        dion gillard added a comment -

        Fixed in 1.4-SNAPSHOT of javadoc plugin


          People

          • Assignee:
            Unassigned
            Reporter:
            Nick Giles
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: