Maven 1.x Javadoc Plugin
  1. Maven 1.x Javadoc Plugin
  2. MPJAVADOC-61

StringIndexOutOfBoundsException on parsing the files

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.8
    • Labels:
      None
    • Environment:
      Maven 1.1b1 and b2, Windows 2K
    • Number of attachments :
      2

      Description

      Happens on 1.1 b1 and b2.

      While parsing, throws:

      Caught exception evaluating: org.apache.commons.jexl.ExpressionImpl@8de972. Reason: java.lang.StringIndexOutOfBoundsException: String index out of range: -60
      java.lang.StringIndexOutOfBoundsException: String index out of range: -60
      at java.lang.String.substring(String.java:1444)
      at java.lang.String.substring(String.java:1411)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.commons.jexl.util.introspection.UberspectImpl$VelMethodImpl.invoke(UberspectImpl.java:268)
      [snip]

      This causes a rather empty Javadoc Warnings report (but Javadoc Report is good):

      JavaDoc Warnings

      The following document contains JavaDoc warnings.
      Summary
      Files Errors
      24 0
      Files
      Files Errors

      I am not sure what info to provide - please ask!

      1. stacktrace.log
        62 kB
        Jeff Jensen

        Activity

        Jeff Jensen added a comment -

        Got it, thanks. Yes, with debug on, I see the NFE. Well, at least we now know what the problem is! Thank you for all the advice and knowledge to track it down.

        Lukas Theussl added a comment -

        Jeff, I just committed a fix to the javadoc-plugin svn, can you test please?

        Jeff Jensen added a comment -

        Checked out revision 355960. Built it and it ran great!!

        These messages you added nicely show where the previous problems were

            • WARNING: no line number found in 'C:\devroot\customers\dhs\perforce\healthmatchbatch\main\src\java\us\state\vantage\hm\batch\ar\policy\premiumduedate\package.html', setting to 0.

        So the Javadoc HTML files (package.html, overview.html) with problems now correctly list in the Javadoc Warnings Report. Awesome!

        Thank you very much for adding this use case to the Javadoc plugin.

        Jeff Jensen added a comment -

        Lukas, Do you plan to post another 1.8-SNAPSHOT at http://cvs.apache.org/repository/maven/plugins/ with this enhancement?

        Lukas Theussl added a comment -

        Done.


          People

          • Assignee:
            Unassigned
            Reporter:
            Jeff Jensen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: