Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7
    • Labels:
      None
    • Environment:
      MAVEN 1.0(.1) BRANCH + JDK 1.3
    • Number of attachments :
      1

      Description

      [exec] +----------------------------------------
      [exec] | Installing Maven Javadoc Plug-in
      [exec] | Memory: 21M/23M
      [exec] +----------------------------------------
      [exec] Tag library requested that is not present: 'artifact' in plugin: 'plugin'

      [exec] build:end:

      [exec] build:start:

      [exec] clean:clean:
      [exec] [delete] Deleting directory C:\Work\Opensources\maven-plugins\javadoc\target
      [exec] Tag library requested that is not present: 'artifact' in plugin: 'jar'
      [exec] Tag library requested that is not present: 'deploy' in plugin: 'jar'
      [exec] Tag library requested that is not present: 'doc' in plugin: 'jar'
      [exec] Tag library requested that is not present: 'doc' in plugin: 'jar'

      [exec] clean:

      [exec] plugin:plugin:
      [exec] java:prepare-filesystem:
      [exec] [mkdir] Created dir: C:\Work\Opensources\maven-plugins\javadoc\target\classes

      [exec] java:compile:
      [exec] [echo] Compiling to C:\Work\Opensources\maven\..\maven-plugins\javadoc/target/classes
      [exec] [javac] Compiling 1 source file to C:\Work\Opensources\maven-plugins\javadoc\target\classes
      [exec] C:\Work\Opensources\maven-plugins\javadoc\src\main\org\apache\maven\javadoc\JavadocWarningsTextToXml.java:35: cannot resolve sym
      bol
      [exec] symbol : class LinkedHashSet
      [exec] location: package util
      [exec] import java.util.LinkedHashSet;
      [exec] ^
      [exec] C:\Work\Opensources\maven-plugins\javadoc\src\main\org\apache\maven\javadoc\JavadocWarningsTextToXml.java:282: cannot resolve sy
      mbol
      [exec] symbol : class LinkedHashSet
      [exec] location: class org.apache.maven.javadoc.JavadocWarningsTextToXml
      [exec] lineMessages = new LinkedHashSet();
      [exec] ^
      [exec] 2 errors

      [exec] BUILD FAILED
      [exec] com.werken.werkz.UnattainableGoalException: Unable to obtain goal [plugin:plugin] – C:\Programs\dev\apache-maven-1.0\plugins\ja
      va\plugin.jelly:52:48: <ant:javac> Compile failed; see the compiler error output for details.
      [exec] at com.werken.werkz.Goal.fire(Goal.java:646)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:575)
      [exec] at com.werken.werkz.Goal.attainPrecursors(Goal.java:488)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:573)
      [exec] at com.werken.werkz.WerkzProject.attainGoal(WerkzProject.java:193)
      [exec] at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:634)
      [exec] at org.apache.maven.MavenSession.attainGoals(MavenSession.java:266)
      [exec] at org.apache.maven.jelly.tags.maven.ReactorTag.doTag(ReactorTag.java:342)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      [exec] at com.werken.werkz.Goal.fire(Goal.java:639)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:575)
      [exec] at com.werken.werkz.WerkzProject.attainGoal(WerkzProject.java:193)
      [exec] at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:634)
      [exec] at org.apache.maven.MavenSession.attainGoals(MavenSession.java:266)
      [exec] at org.apache.maven.cli.App.doMain(App.java:486)
      [exec] at org.apache.maven.cli.App.main(App.java:1215)
      [exec] at java.lang.reflect.Method.invoke(Native Method)
      [exec] at com.werken.forehead.Forehead.run(Forehead.java:551)
      [exec] at com.werken.forehead.Forehead.main(Forehead.java:581)
      [exec] org.apache.commons.jelly.JellyTagException: C:\Programs\dev\apache-maven-1.0\plugins\java\plugin.jelly:52:48: <ant:javac> Compil
      e failed; see the compiler error output for details.
      [exec] at org.apache.commons.jelly.impl.TagScript.handleException(TagScript.java:683)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:288)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:233)
      [exec] at org.apache.commons.jelly.tags.core.WhenTag.doTag(WhenTag.java:92)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:233)
      [exec] at org.apache.commons.jelly.tags.core.ChooseTag.doTag(ChooseTag.java:84)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      [exec] at com.werken.werkz.Goal.fire(Goal.java:639)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:575)
      [exec] at com.werken.werkz.Goal.attainPrecursors(Goal.java:488)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:573)
      [exec] at com.werken.werkz.Goal.attainPrecursors(Goal.java:488)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:573)
      [exec] at com.werken.werkz.Goal.attainPrecursors(Goal.java:488)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:573)
      [exec] at com.werken.werkz.WerkzProject.attainGoal(WerkzProject.java:193)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenAttainGoalTag.doTag(MavenAttainGoalTag.java:127)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      [exec] at com.werken.werkz.Goal.fire(Goal.java:639)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:575)
      [exec] at com.werken.werkz.Goal.attainPrecursors(Goal.java:488)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:573)
      [exec] at com.werken.werkz.WerkzProject.attainGoal(WerkzProject.java:193)
      [exec] at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:634)
      [exec] at org.apache.maven.MavenSession.attainGoals(MavenSession.java:266)
      [exec] at org.apache.maven.jelly.tags.maven.ReactorTag.doTag(ReactorTag.java:342)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      [exec] at com.werken.werkz.Goal.fire(Goal.java:639)
      [exec] Root cause
      [exec] at com.werken.werkz.Goal.attain(Goal.java:575)
      [exec] at com.werken.werkz.WerkzProject.attainGoal(WerkzProject.java:193)
      [exec] at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:634)
      [exec] at org.apache.maven.MavenSession.attainGoals(MavenSession.java:266)
      [exec] at org.apache.maven.cli.App.doMain(App.java:486)
      [exec] at org.apache.maven.cli.App.main(App.java:1215)
      [exec] at java.lang.reflect.Method.invoke(Native Method)
      [exec] at com.werken.forehead.Forehead.run(Forehead.java:551)
      [exec] at com.werken.forehead.Forehead.main(Forehead.java:581)
      [exec] Compile failed; see the compiler error output for details.
      [exec] at org.apache.tools.ant.taskdefs.Javac.compile(Javac.java:844)
      [exec] at org.apache.tools.ant.taskdefs.Javac.execute(Javac.java:682)
      [exec] at org.apache.tools.ant.Task.perform(Task.java:341)
      [exec] at org.apache.commons.jelly.tags.ant.AntTag.doTag(AntTag.java:186)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:233)
      [exec] at org.apache.commons.jelly.tags.core.WhenTag.doTag(WhenTag.java:92)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:233)
      [exec] at org.apache.commons.jelly.tags.core.ChooseTag.doTag(ChooseTag.java:84)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      [exec] at com.werken.werkz.Goal.fire(Goal.java:639)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:575)
      [exec] at com.werken.werkz.Goal.attainPrecursors(Goal.java:488)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:573)
      [exec] at com.werken.werkz.Goal.attainPrecursors(Goal.java:488)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:573)
      [exec] at com.werken.werkz.Goal.attainPrecursors(Goal.java:488)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:573)
      [exec] at com.werken.werkz.WerkzProject.attainGoal(WerkzProject.java:193)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenAttainGoalTag.doTag(MavenAttainGoalTag.java:127)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      [exec] at com.werken.werkz.Goal.fire(Goal.java:639)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:575)
      [exec] at com.werken.werkz.Goal.attainPrecursors(Goal.java:488)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:573)
      [exec] at com.werken.werkz.WerkzProject.attainGoal(WerkzProject.java:193)
      [exec] at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:634)
      [exec] at org.apache.maven.MavenSession.attainGoals(MavenSession.java:266)
      [exec] at org.apache.maven.jelly.tags.maven.ReactorTag.doTag(ReactorTag.java:342)
      [exec] at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      [exec] at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      [exec] at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      [exec] at com.werken.werkz.Goal.fire(Goal.java:639)
      [exec] at com.werken.werkz.Goal.attain(Goal.java:575)
      [exec] at com.werken.werkz.WerkzProject.attainGoal(WerkzProject.java:193)
      [exec] at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:634)
      [exec] at org.apache.maven.MavenSession.attainGoals(MavenSession.java:266)
      [exec] at org.apache.maven.cli.App.doMain(App.java:486)
      [exec] at org.apache.maven.cli.App.main(App.java:1215)
      [exec] at java.lang.reflect.Method.invoke(Native Method)
      [exec] at com.werken.forehead.Forehead.run(Forehead.java:551)
      [exec] at com.werken.forehead.Forehead.main(Forehead.java:581)
      [exec] File...... C:\Work\Opensources\maven\maven.xml
      [exec] Element... maven:reactor
      [exec] Line...... 115
      [exec] Column.... 7
      [exec] Unable to obtain goal [plugin:plugin] – C:\Programs\dev\apache-maven-1.0\plugins\java\plugin.jelly:52:48: <ant:javac> Compile f
      ailed; see the compiler error output for details.
      [exec] Total time: 3 minutes 59 seconds
      [exec] Finished at: Fri Sep 03 16:16:59 CEST 2004

        Activity

        Arnaud Heritier added a comment -

        Patch to replace the LinkedHashSet (only 1.4) by a HashSet

        Felipe Leme added a comment -

        Arnaud,

        Notice that LinkedHashSet is a "Hash table and linked list implementation of the Set interface, with predictable iteration order".

        I'm not sure why it was used at first place, but if it was chosen due to the predictable iteration order, then we better replace it by some class on Commons Collection.

        – Felipe

        Arnaud Heritier added a comment -

        I will investigate because I actually didn't find why it was used.


          People

          • Assignee:
            Arnaud Heritier
            Reporter:
            Arnaud Heritier
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: