Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Run plugin:test for the html2xdoc plugin and you get this:
      BUILD FAILED
      File...... C:\Documents and Settings\Dion Gillard\.maven\cache\maven-plugin-plugin-1.5.2-SNAPSHOT\plugin.jelly
      Element... maven:maven
      Line...... 314
      Column.... 34
      Unable to obtain goal [test-html2xdoc-site] – C:\Documents and Settings\Dion Gillard\.maven\cache\maven-javadoc-plugin-1.7-SNAPSHOT
      \plugin.jelly:115:57: <ant:copy> Specify at least one source - a file or a fileset.
      Total time: 4 seconds
      Finished at: Thu Sep 02 11:02:58 EST 2004

        Activity

        Arnaud Heritier added a comment -

        I don't reproduce this problem with the current maven-core (HEAD branch) and JDK 1.4.
        But I have a problem if I use a JDK 1.3 (certainly due to the last jelly update) :
        ==================================================================
        D:\Work\Dev\maven-plugins\html2xdoc>maven -Dmaven.javadoc.debug=true plugin:test
        __ __

        \/ __ Apache_ ___
          \/ / ` \ V / -) ' \ ~ intelligent projects ~
        _   _,_ _/___ _ _ v. 1.1-SNAPSHOT

        File...... null
        Element... j:if
        Line...... 33
        Column.... 34
        java.lang.NoSuchMethodError

        You have encountered an unknown error running Maven. Please help us to correct
        this problem by following these simple steps:

        Total time: 1 seconds
        Finished at: Thu Sep 02 22:25:25 CEST 2004

        D:\Work\Dev\maven-plugins\html2xdoc>
        =====================================================================

        I tried to build maven with the jdk 1.3 but I have the same problem

        dion gillard added a comment -

        I tried with JDK1.4:

        C:\source\maven-plugins\html2xdoc\src\plugin-test>set JAVA_HOME=c:\j2sdk1.4.2_03

        C:\source\maven-plugins\html2xdoc\src\plugin-test>maven site
        __ __

        \/ __ Apache_ ___
          \/ / ` \ V / -) ' \ ~ intelligent projects ~
        _   _,_ _/___ _ _ v. 1.0.1-SNAPSHOT

        build:start:

        site:
        xdoc:register-reports:
        maven-jdepend-plugin:register:

        maven-checkstyle-plugin:register:

        maven-changes-plugin:register:

        maven-changelog-plugin:register:

        maven-developer-activity-plugin:register:

        maven-file-activity-plugin:register:

        maven-license-plugin:register:

        xdoc:init:
        [echo] html2xdoc is enabled
        html2xdoc:transform:
        [echo] Generating C:/source/maven-plugins/html2xdoc/src/plugin-test/target/generated-xdocs/h1h2.xml from C:\source\maven-plugins
        \html2xdoc\src\plugin-test\xdocs\h1h2.html

        BUILD FAILED
        File...... C:\Documents and Settings\Dion Gillard\.maven\cache\maven-javadoc-plugin-1.7-SNAPSHOT\plugin.jelly
        Element... ant:copy
        Line...... 115
        Column.... 57
        Specify at least one source - a file or a fileset.
        Total time: 4 seconds
        Finished at: Fri Sep 03 09:08:19 EST 2004

        dion gillard added a comment -

        Arnaud, you're in the wrong directory to reproduce the problem.

        You need to be in:

        maven-plugins/html2xdoc/src/plugin-test

        Arnaud Heritier added a comment -

        It works also for me.
        But I think that it is because I use maven HEAD and not maven 1.0 branch.
        I'll try with the 1.0 branch.


          People

          • Assignee:
            Arnaud Heritier
            Reporter:
            dion gillard
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: