Maven 1.x Javadoc Plugin
  1. Maven 1.x Javadoc Plugin
  2. MPJAVADOC-41

Javadoc does not get created with multiple entries in maven.compile.src.set

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.1
    • Fix Version/s: 1.7
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The problem is that internal.javadoc.needed is set for every entry in maven.compile.src.set. So later entries that do not require generation, override entries that did, and nothing gets built.

        Activity

        Arnaud Heritier added a comment -

        Can you test the javadoc plugin in CVS ? I think that I resolved this problem recently.
        I can send you the plugin if you don't want or if you can't build the plugin on CVS.
        Do you have a test case ?

        Kenneth Leider added a comment -

        I'll try the new one. I think that the issue has been fixed by changing
        internal.javadoc.needed to internal_javadoc_needed. At least my experience has shown that putting periods in variable is bad news.

        Thanks

        Arnaud Heritier added a comment -

        yes it was an error because in jelly syntax, dots are used as getters.
        internal.javadoc.needed was replaced by internal.getJavadoc().getNeeded()


          People

          • Assignee:
            Arnaud Heritier
            Reporter:
            Kenneth Leider
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: