Maven 1.x Javadoc Plugin
  1. Maven 1.x Javadoc Plugin
  2. MPJAVADOC-11

Javadoc plugin fails with java.io.IOException: CreateProcess...

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      1

      Description

      The Javadoc plugin fails with java.io.IOException: CreateProcess ... if you have a great number of classes.
      The problem is caused by the ant javadoc task that generate a command line greater the 64k. The solution is siply add the useexternalfile="yes" attribute to the ant task

      1. path.txt
        0.4 kB
        Simone Zorzetti

        Activity

        Simone Zorzetti added a comment -

        Patch to src\plugins-build\javadoc\plugin.jelly

        Emmanuel Venisse added a comment -

        Done.


          People

          • Assignee:
            Unassigned
            Reporter:
            Simone Zorzetti
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: