Maven 1.x Jar Plugin
  1. Maven 1.x Jar Plugin
  2. MPJAR-51

REDUX: Specification-Version and Implementation-Vendor-Id not being set

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      http://jira.codehaus.org/browse/MPJAR-7?rc=1 commented out code to set the Specification-Version manifect attribute. There seems to have been quite a bit of debate about that bug. The result seems to be that the code was commented out http://svn.apache.org/viewcvs.cgi/maven/maven-1/plugins/trunk/jar/plugin.jelly?rev=115072&r1=115041&r2=115072&diff_format=h so that the RC3 could ship and a more permenent solution found later. It's still there.

      Specification-Version should really be set for libraries: IIRC there are some fancy EJB library loading routines which rely on it. Personally speaking, I'd be happen to uncomment the commented line.

        Issue Links

          Activity

          Jörg Schaible added a comment -

          Problem is, that the manifest spec does only allow number values for the specification version entry. So that entry should not have a version that ends e.g. with -SNAPSHOT. I solved this in the javaapp plugin by extracting major.minor from the version unless it is overwritten with a property (http://maven-plugins.sourceforge.net/maven-javaapp-plugin/properties.html).

          Robert Burrell Donkin added a comment -

          +1

          using major.minor is just what we need for the commons.

          later versions of the jar specification (http://java.sun.com/j2se/1.5.0/docs/guide/extensions/versioning.html) mean that we really need the implementation-vendor-id set as well. i wonder whether basising this on the organization url (http://www.apache.org -> org.apache) might be about right.

          Carlos Sanchez added a comment -

          Dupe of MPJAR-39


            People

            • Assignee:
              Carlos Sanchez
              Reporter:
              Robert Burrell Donkin
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: