Maven Project Info Reports Plugin
  1. Maven Project Info Reports Plugin
  2. MPIR-81

DependenciesRenderer logs Exception when it can't find the artifact being built!!!

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Using a version of "Project Info Reports Plugin" built from the current svn repo produces the following exception stack trace in the output when using "mvn site" on commons-chain-1.2-SNAPSHOT when that snapshot version isn't in my local repository. If I do "mvn install" first and then run it works OK. In both scenarios though the dependecies report is produced OK - seems strange through to be throuwing an exception when the artifact being built can't be found!

      [ERROR] Artifact: commons-chain:commons-chain:jar:1.2-SNAPSHOT has no file.
      org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download the artifact from any repository

      Try downloading the file manually from the project website.

      Then, install it using the command:
      mvn install:install-file -DgroupId=commons-chain -DartifactId=commons-chain \
      -Dversion=1.2-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
      Alternatively, if you host your own repository you can deploy the file there: mvn deploy:deploy-file -DgroupId=commons-chain -DartifactId=commons-chain \
      -Dversion=1.2-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file \
      -Durl=[url] -DrepositoryId=[id]

      commons-chain:commons-chain:jar:1.2-SNAPSHOT

      from the specified remote repositories:
      central (http://repo1.maven.org/maven2)

      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:197)
      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:73)
      at org.apache.maven.report.projectinfo.dependencies.RepositoryUtils.resolve(RepositoryUtils.java:114)
      at org.apache.maven.report.projectinfo.dependencies.renderer.DependenciesRenderer.renderSectionDependencyFileDetails(DependenciesRenderer.java:339)
      at org.apache.maven.report.projectinfo.dependencies.renderer.DependenciesRenderer.renderBody(DependenciesRenderer.java:176)
      at org.apache.maven.reporting.AbstractMavenReportRenderer.render(AbstractMavenReportRenderer.java:65)
      at org.apache.maven.report.projectinfo.DependenciesReport.executeReport(DependenciesReport.java:158)
      at org.apache.maven.reporting.AbstractMavenReport.generate(AbstractMavenReport.java:101)
      at org.apache.maven.plugins.site.ReportDocumentRenderer.renderDocument(ReportDocumentRenderer.java:139)
      at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.renderModule(DefaultSiteRenderer.java:269)
      at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.render(DefaultSiteRenderer.java:101)
      at org.apache.maven.plugins.site.SiteMojo.renderLocale(SiteMojo.java:129)
      at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:96)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:443)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:539)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:480)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:459)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:311)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:278)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:143)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:334)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:125)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:280)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable to download the artifact from any repository
      at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:324)
      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:185)
      ... 30 more

        Activity

        Vincent Siveton added a comment -

        log a warning instead of error


          People

          • Assignee:
            Vincent Siveton
            Reporter:
            Niall Pemberton
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: