Maven Project Info Reports Plugin
  1. Maven Project Info Reports Plugin
  2. MPIR-65

Direct report generation breaks on skin version even though it is specified

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.1
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      /ggg/src/site/site.xml contains the skin declaration like this:
      <skin>
      <groupId>org.apache.maven.skins</groupId>
      <artifactId>maven-default-skin</artifactId>
      <version>1.0</version>
      </skin>

      In /ggg I can run
      mvn site
      without a problem (it does compile the code though).
      but if I run
      mvn project-info-reports:dependencies
      That breaks with this error message:

      [INFO] The skin does not exist: Unable to determine the release version

      Try downloading the file manually from the project website.

      Then, install it using the command:
      mvn install:install-file -DgroupId=org.apache.maven.skins -DartifactId=maven-default-skin \
      -Dversion=RELEASE -Dpackaging=jar -Dfile=/path/to/file

      org.apache.maven.skins:maven-default-skin:jar:RELEASE

        Activity

        Vincent Siveton added a comment -

        I was unable to reproduce your pb. I tried with 2.0.1 and the snapshot.


          People

          • Assignee:
            Vincent Siveton
            Reporter:
            Geoffrey De Smet
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: