Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0-beta-3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Ubuntu /Windows 2000
    • Number of attachments :
      1

      Description

      With mvn site:site we got a NPE at org.apache.maven.aritfact.resolver.DefaultArtifactResolver.java Line 82

        Issue Links

          Activity

          Jeff Jensen added a comment -
          Bernd Bohmann added a comment -

          Yes

          Bernd Bohmann added a comment -

          patch included

          Carlos Sanchez added a comment -

          Dupe of MNG-1663
          I don't think this patch will work

          Bernd Bohmann added a comment -

          Why I should include a patch if the patch doesn't solve the problem?

          Bernd Bohmann added a comment -

          Or can you explain me the difference between file doesn't exist or the file is null at this place?

          Carlos Sanchez added a comment -

          AFAIK with this patch you'd get a ArtifactNotFoundException.
          The problem is in the dependencies report, that shouldn't try to call that class when it's a system dependency

          Bernd Bohmann added a comment -

          The core question is:
          Can artifact.getFile() return null?
          If so the patch should applied if not the reason for the null should be fixed.

          Brett Porter added a comment -

          the patch should not be applied. The file should not be null once the artifact is resolved.

          Does the problem still exist with the latest project-info-reports-plugin where the bug we seem to be tracking is fixed?

          Bernd Bohmann added a comment -

          I think it it fixed in the latest version.
          But I see from time to time a message on the list NPE in DefaultArtifactResolver ..

          Or is this not the method that try to resolve the artifact?r

          domi added a comment -

          When is this fix within an official releade? I'think I run the latest version and still have this problem!

          Daniel Holmen added a comment -

          This NPE still happens for system scoped dependencies in 2.0.3. Is it fixed in the svn repository?

          Julian Wood added a comment -

          Still not fixed as of maven 2.0.4, and yet all this issue and all its duplicates are closed, AFAICT.


            People

            • Assignee:
              Carlos Sanchez
              Reporter:
              Bernd Bohmann
            • Votes:
              5 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: