Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.5
    • Component/s: dependency-management
    • Labels:
      None
    • Environment:
    • Number of attachments :
      0

      Description

      I was kind of surprised to see maven 3.0.5-SNAPSHOT being downloaded. Looks like a bug to me.
      This happend during a mvn site on the coberturta-maven-plugin rev. 15529

      [INFO] Generating "Dependency Management" report    --- maven-project-info-reports-plugin:2.4
      [INFO] artifact org.apache.maven:maven-plugin-api: checking for updates from nexus
      Downloading: http://localhost:8081/nexus/content/groups/public/org/apache/maven/maven-plugin-api/3.0.5-SNAPSHOT/maven-metadata.xml
      Downloaded: http://localhost:8081/nexus/content/groups/public/org/apache/maven/maven-plugin-api/3.0.5-SNAPSHOT/maven-metadata.xml (782 B at 0.3 KB/sec)
      Downloading: http://localhost:8081/nexus/content/groups/public/org/apache/maven/maven-plugin-api/3.0.5-SNAPSHOT/maven-plugin-api-3.0.5-20111209.224224-4.pom
      Downloaded: http://localhost:8081/nexus/content/groups/public/org/apache/maven/maven-plugin-api/3.0.5-SNAPSHOT/maven-plugin-api-3.0.5-20111209.224224-4.pom (3 KB at 2.3 KB/sec)
      Downloading: http://localhost:8081/nexus/content/groups/public/org/apache/maven/maven/3.0.5-SNAPSHOT/maven-metadata.xml
      Downloaded: http://localhost:8081/nexus/content/groups/public/org/apache/maven/maven/3.0.5-SNAPSHOT/maven-metadata.xml (809 B at 0.3 KB/sec)
      Downloading: http://localhost:8081/nexus/content/groups/public/org/apache/maven/maven/3.0.5-SNAPSHOT/maven-3.0.5-20111209.224136-4.pom
      Downloaded: http://localhost:8081/nexus/content/groups/public/org/apache/maven/maven/3.0.5-SNAPSHOT/maven-3.0.5-20111209.224136-4.pom (22 KB at 7.7 KB/sec)
      [INFO] artifact junit:junit: checking for updates from nexus
      

        Issue Links

          Activity

          Robert Scholte added a comment -

          This issue depends on the maven-version

          Maven Version maven-plugin-api version download
          2.2.1 3.0.3
          3.0.1 3.0.3
          3.0.2 3.0.3
          3.0.3 3.0.5-SNAPSHOT
          3.0.4-RC2 3.0.5-SNAPSHOT
          3.0.4-RC3 3.0.3

          At least with 3.0.4-RC3 it won't download the LATEST but the RELEASED version.

          jieryn added a comment -

          What's going on with this one? This dramatically slows down site generation.. and seems completely useless.

          Herve Boutemy added a comment -

          this is probably due to the fact that maven-dependency-tree component does wrong calculation when used with Maven 3, since the whole dependency resolution code has been changed: it is a known issue not fixed yet

          Robert Scholte added a comment -

          Jieryn, I can't reproduce it with Maven-3.0.4 (i.e. final version). It downloads the maven-plugin-api:3.0.4 as expected.
          It's true that this is one of the slowest pages, but that's another issue.

          jieryn added a comment -
          <!-- snip from help:effective-pom -->
            <dependencyManagement>
              <dependencies>
                <dependency>
                  <groupId>commons-beanutils</groupId>
                  <artifactId>commons-beanutils</artifactId>
                  <version>1.8.3</version>
                </dependency>
              </dependencies>
            </dependencyManagement>
          
          <!-- snip from mvn site (v3.1) -->
          
          [INFO] Generating "Dependency Management" report    --- maven-project-info-reports-plugin:2.4
          [INFO] artifact commons-beanutils:commons-beanutils: checking for updates from maven.acme.com
          Downloading: http://maven.acme.com/repository/all/commons-beanutils/commons-beanutils/1.8.4-SNAPSHOT/maven-metadata.xml
          Downloaded: http://maven.acme.com/repository/all/commons-beanutils/commons-beanutils/1.8.4-SNAPSHOT/maven-metadata.xml (371 B at 0.2 KB/sec)
          
          jieryn added a comment -

          I do not use commons-beanutils:1.8.4-SNAPSHOT anywhere, and I see this for pretty much every single dependency in my dM section (for which, there are hundreds – because this is a top level corporate pom to standardize all projects dependencies' versions).

          Generating that dependency management report can take over an hour, and mostly just to download snapshot poms for junk we're not even using yet.

          Herve Boutemy added a comment -

          fixed in r1348664


            People

            • Assignee:
              Herve Boutemy
              Reporter:
              Robert Scholte
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: