Maven Project Info Reports Plugin
  1. Maven Project Info Reports Plugin
  2. MPIR-106

Regression in 2.1-SNAPSHOT, the Project Dependencies and the Project Transitive Dependencies are the same

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1
    • Component/s: dependencies
    • Labels:
      None
    • Environment:
      Windows, Maven 2.08, Project Info Reports Plugin 2.1-SNAPSHOT
    • Number of attachments :
      0

      Description

      In the 2.0.1, in the "Project Dependencies " we find only the direct dependency, and in the "Project Transitive Dependencies" we find all dependency (direct and transitive).

      in 2.1-SNAPSHOT, both report are same. Then, in Project Dependencies we find the transitive dependency too.

        Issue Links

          Activity

          Vincent Siveton added a comment -

          This issue is due to MPIR-76, which updated maven-dependency-tree to 1.1

          Arnaud added a comment -

          So the probleme is in maven-dependency-tree ?

          But in his JIRA there are no ticket open for this probleme . http://jira.codehaus.org/browse/MDEP/component/12849

          I can open it ?

          Vincent Siveton added a comment -

          Thanks Arnaud but the problem was in MPIR report. MPIR-76 did not update the code.
          I fixed it in r674456 and a snapshot was deployed.


            People

            • Assignee:
              Vincent Siveton
              Reporter:
              Arnaud
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: