Maven Help Plugin
  1. Maven Help Plugin
  2. MPH-38

mvn help:active-profiles won't show the active profiles in settings.xml

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      linux (never tried it in windows), sun's jdk 1.5.0_12
    • Number of attachments :
      1

      Description

      settings.xml has this

      <activeProfiles>
      <activeProfile>appserverConfig</activeProfile>
      </activeProfiles>

      pom.xml of MavenProject2 project has this

      <profile>
      <id>appserverConfig-dev-2</id>
      <activation>
      <activeByDefault>true</activeByDefault>
      <property>
      <name>env</name>
      <value>dev-2</value>
      </property>
      </activation>
      <properties>
      <appserver.home>/path/to/another/dev/appserver2</appserver.home>
      </properties>
      </profile>

      I tried mvn help:active-profiles using the maven 2.1-SNAPSHOT I only got

      • appserverConfig-dev-2 (source: pom)

      appserverConfig defined in settings.xml is not shown

        Issue Links

          Activity

          Julie Pitt added a comment -

          I am having the exact same issue on windows with JDK 1.5.0_14

          Vincent Siveton added a comment -

          It is a normal way since appserverConfig is not a profile defined in your settings. You should activate an existing profile.

          Allan G. Ramirez added a comment -

          Sorry for not posting the whole settings.xml of mine. But appserverConfig is defined or existed in my settings when I tested it.

          I'm attaching the maven cli that I used for testing.

          Vincent Siveton added a comment -

          Since it works with mvn 2.0.9, I guess it is a regression in mvn 2.1

          Brett Porter added a comment -

          no longer an issue due to the linked fix


            People

            • Assignee:
              Brett Porter
              Reporter:
              Allan G. Ramirez
            • Votes:
              3 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: