Maven 1.x Eclipse Plugin
  1. Maven 1.x Eclipse Plugin
  2. MPECLIPSE-125

M1: If using JAR override, new sources feature does not work.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.11
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I'm using SNMP4J, version 1.7.2. This project does not currently reside in any public repositories, so we have it in a 'lib' directory in our SCM and use a jar override to pick it up. I downloaded the source for it and placed it in my local repository. When I run "maven eclipse", it never even attempts to look for this source. Seems like overridden dependencies are ignored.

        Activity

        Hide
        Michael Osipov added a comment -

        Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.

        Show
        Michael Osipov added a comment - Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.

          People

          • Assignee:
            Unassigned
            Reporter:
            Jamie Bisotti
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: