Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.11
    • Fix Version/s: 1.12
    • Labels:
      None
    • Number of attachments :
      1

      Description

      latest Plugin doesn't attach javadoc jar in the Eclipse Classpath. This is caused by a copy/paste of the chek-file-exists block that doesn't use the "jdocs" variable.

      It would be great also to try downloading the javadocs when no sources jar is available : for example, the Oracle JDBC driver is closed-source but has javadoc that can be deployed in a corporate repository and be available to all corporate developpers.

        Activity

        nicolas de loof added a comment -

        Sory for bad diagnostic, I was reading a modified plugin.jelly, not the SVN one.

        According to plugin code, this is an expected behaviour as Eclipse before 3.2 doesn't support MAVEN_REPO classpath variable for javadoc attachement.

        Maybe a property could make use of javadocs jars optional ? Maybe an eclipse version property could be usefull for other goals in this plugin, and could enable javadocs attachement / download ?

        nicolas de loof added a comment -

        It seems there not a better support for classpath variables for javadoc in Eclipse 3.2

        nicolas de loof added a comment -

        This patch enables javadocs downloading when sources are not available. javadoc jar is added to .classpath using an absolute path due to lack of support for MAVEN_REPO classpath variable in Eclipse. As this classpath file can easily be re-created, I don't think this is a good reason for blocking this functionnality.

        Patch contains code + doc improvement

        Stéphane Nicoll added a comment -

        This is fixed, thanks but:

        • The patch was not on the latest version of SVN so it was a bit difficult to apply ; please rebuild from SVN and test your projects
        • The copy paste of code was not really nice so I introduced an abstract class with common codes.

          People

          • Assignee:
            Stéphane Nicoll
            Reporter:
            nicolas de loof
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: